Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Salesforce Input Step Errors

  1. #1
    Join Date
    Jul 2009
    Posts
    3

    Question Salesforce Input Step Errors

    Hello,
    We are using the Salesforce Input step available in v3.2 for data extraction from SF. As of Thursday morning, 7/16, our transformations have started failing on the input step due to a class not found error. (below).

    Has anyone else run into this issue? Is it possible that Salesforce has stopped supporting version 10? We are dead at the moment with a process that has been operating for months.




    Unable to open dialog for this step
    java.lang.NoClassDefFoundError: com/sforce/soap/partner/SforceServiceLocator
    at org.pentaho.di.ui.trans.steps.salesforceinput.SalesforceInputDialog.getBinding(SalesforceInputDialog.java:911)
    at org.pentaho.di.ui.trans.steps.salesforceinput.SalesforceInputDialog.test(SalesforceInputDialog.java:882)
    at org.pentaho.di.ui.trans.steps.salesforceinput.SalesforceInputDialog.access$1100(SalesforceInputDialog.java:81)
    at org.pentaho.di.ui.trans.steps.salesforceinput.SalesforceInputDialog$10.handleEvent(SalesforceInputDialog.java:770)
    at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
    at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
    at org.pentaho.di.ui.trans.steps.salesforceinput.SalesforceInputDialog.open(SalesforceInputDialog.java:830)
    at org.pentaho.di.ui.spoon.delegates.SpoonStepsDelegate.editStep(SpoonStepsDelegate.java:123)
    at org.pentaho.di.ui.spoon.Spoon.editStep(Spoon.java:6274)
    at org.pentaho.di.ui.spoon.trans.TransGraph.editStep(TransGraph.java:2296)
    at org.pentaho.di.ui.spoon.trans.TransGraph.access$100(TransGraph.java:150)
    at org.pentaho.di.ui.spoon.trans.TransGraph$6.mouseDoubleClick(TransGraph.java:454)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(Unknown Source)
    at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
    at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
    at org.pentaho.di.ui.spoon.Spoon.readAndDispatch(Spoon.java:945)
    at org.pentaho.di.ui.spoon.Spoon.start(Spoon.java:5574)
    at org.pentaho.di.ui.spoon.Spoon.main(Spoon.java:412)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.pentaho.commons.launcher.Launcher.main(Launcher.java:116)
    Caused by: java.lang.ClassNotFoundException: com.sforce.soap.partner.SforceServiceLocator
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
    ... 27 more

  2. #2

    Default

    Hi,

    I tested and it works.
    Do you still have this error?

    Thanks

    Samatar
    Samatar

  3. #3
    Join Date
    Jul 2009
    Posts
    3

    Default

    Yes, we are still getting the same error. I have even tried installing 3.2 on a personal computer here in the office(i.e. no corporate antivirus, internet only machine), and I am still getting the same error when creating a new transformation from scratch.

    Could this be a network related issue?

  4. #4

    Default

    Ok

    Which OS are you using?
    If it's windows, do you running kettle.exe ou spoon.bat?
    If you are still here, can you try by launching spoon.bat.

    Thanks

    Samatar
    Samatar

  5. #5
    Join Date
    Jul 2009
    Posts
    3

    Default

    Quote Originally Posted by shassan2 View Post
    Ok

    Which OS are you using?
    If it's windows, do you running kettle.exe ou spoon.bat?
    If you are still here, can you try by launching spoon.bat.

    Thanks

    Samatar

    Thank you Samatar, that did it. Now my next question is why...

    Why doesn't Kettle.exe set the classpath? (I am assuming that is the issue)

    Thanks again,
    Dan.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.