Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Adhoc Reporting Grouping not works

  1. #1

    Default Adhoc Reporting Grouping not works

    Hi

    I am trying to develop a adhoc report using pentaho community edition bi suite 3.0 and metadata editor.

    I developed business model, business views, etc.
    my sql query result returns 30 rows with 3 distinct dates (each having 10 rows) in it. When i try to group the report based on that date, it should return 10 rows under each group.

    But all the records are displayed in the order it was fetched. But the every page is displaying the group header as i configured.

    Is there any idea how to do grouping in adhoc reporting?

    TIA,
    Senthil.

  2. #2
    Join Date
    Jul 2009
    Posts
    4

    Default

    Sort the data by date while fetching it and that should do it... I faced the same issue while developing a report using the report designer. I added a ORDER BY clause in my SELECT sql to address this issue...

    regards,
    Arun.

  3. #3
    Join Date
    Apr 2007
    Posts
    2,009

    Default

    if you intend to group at the sql level you must set the aggregation function for the relevant fields in the metadata.

    Otherwise grouping is just for display purposes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.