Hitachi Vantara Pentaho Community Forums
Results 1 to 10 of 10

Thread: log encoding

  1. #1
    Join Date
    Sep 2007
    Posts
    834

    Default log encoding

    A simple question:
    how can I change the encoding of the PDI log file?
    We're experimenting problems with special characters (éê ...) in Unix.
    thanks,

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    If I'm not terribly mistaken, log files are written in the UTF-8 encoding.
    We don't have an option yet to change this.
    However, with that encoding you should be able to represent most if not all codepages.
    Perhaps you simply didn't install a certain codepage on the Unix machine?
    In that case it would have trouble displaying the characters as well.

  3. #3
    Join Date
    Sep 2007
    Posts
    834

    Default

    Thank you.
    Well, most of the characters are displayed ok. Here are some sample lines:

    INFO 16-07 14:19:52,621 (LogWriter.java: println:406) -Cr?ation Variable REPRISE_REJECTED_DATA_PATH_06_HYPOTHEQUES.0 - Starting to run...
    INFO 16-07 14:19:53,275 (LogWriter.java: println:406) -Mise en ?chec transformation 1.0 - Finished processing (I=0, O=0, R=0, W=0, U=0, E=0)
    INFO 16-07 14:19:54,423 (LogWriter.java: println:406) -R?cup?re les parametres - Starting entry [reprise_kt_param_006.kjb]
    INFO 16-07 14:19:54,547 (LogWriter.java: println:406) -reprise_kt_param_006 - Finished jobentry [REPRISE_TRANSCODIFICATION_FILE] (result=[true])
    INFO 16-07 14:19:54,654 (LogWriter.java: println:406) -R?cup?re les parametres - Starting entry [Succ?s t?che param]

    Is this a codepage problem? Or could it be something else?
    Thank you!

  4. #4
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    I would suggest to transfer the entire file to Windows and then open it with Wordpad. If I'm not mistaken, that will detect the Unicode codepage.
    If it displays correctly over there, then it's a Unix codepage problem.
    If not, I would have no idea.

    Cheers,
    Matt

  5. #5
    Join Date
    Sep 2007
    Posts
    834

    Default

    Wordpad doesn't show the file correctly.

    Now I'm thinking... All the characters that are displayed incorrectly belong to step names. Maybe the problem is in the encoding of the ktrs/kjbs files.
    Could it be?
    Now I remember that we had similar situations with xaction files, and the solution was changing the encoding of the xaction files.

  6. #6
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    Unless you edit the kjb and ktr files manually, it's unlikely that this is the case. We take great care in making sure that this works fine. It would cause instant problems if we didn't, especially for our Asian users.

    Take a look at the files with Wordpad, see what happens. Open them up in Spoon, see what's being displayed.

    The first line of an XML file specifies the encoding:

    Code:
    <?xml version="1.0" encoding="UTF-8"?>

  7. #7
    Join Date
    Sep 2007
    Posts
    834

    Default

    Before reading this answer, I did the test (changing the header of the ktr, the same we used to do with the xaction files). The transformation run ok, but the log remained wrong. So I desisted...

    The first problem here is that we develop under Windows 2000 (don't ask!) and the productive environment is Unix. When we run from Spoon we don't have this problem.

    Any other idea?
    thanks again,
    mc

  8. #8
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    What is the Language environment on Unix?

    Code:
    set | grep LANG
    Mine says : LANG=nl_BE.UTF-8

    Try setting it to fr_FR.UTF-8 or something like that before running a transformation. Perhaps it's something silly like that.

    Matt

  9. #9
    Join Date
    Sep 2007
    Posts
    834

    Default

    ok! Maybe it is simply that.
    I told the administrators to check this, because I have no permission for doing that.
    thank you

    mc

  10. #10
    Join Date
    Sep 2007
    Posts
    834

    Default

    Finally ... The problem was solved with this command:

    export LANG=fr_FR.ISO8859-15@euro

    thanks,
    mc

    Quote Originally Posted by MattCasters View Post
    What is the Language environment on Unix?

    Code:
    set | grep LANG
    Mine says : LANG=nl_BE.UTF-8

    Try setting it to fr_FR.UTF-8 or something like that before running a transformation. Perhaps it's something silly like that.

    Matt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.