Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Strange problem of pivotLink

  1. #1

    Default Strange problem of pivotLink

    hi

    It's a strange problem, I have a pivotLink component in my dashboard, when I click the link, the popup window redirect to login page, but after I login i, it did’nt show the pivot table. Then I tried the given sample of pivotLink, still got the pb

    As I don't know why, i tried it with the downloaded pentaho version -biserce-ce-3.0, it works well, and directly show the pivot table.

    I guess it's a pb of permission using MDX, but I can't figure out
    maybe have to change something config file since i built the pentaho manuelly.


    Thanks for any helps!!

  2. #2

    Default

    pb is caused by the different base-url between web.xml and the one we type in the broswer, by example
    in the web.xml , base-url: 127.0.0.1
    but in the broswer if the url is locahost, than the pentaho acegi is called to login when call for xactions.(even I tried to authenticate the anonymous role to the dashboard ,that doesn't make it work)

    so better not use ip address as base-url if u get the domaine address.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.