Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Connection in Oracle

  1. #1

    Default Connection in Oracle

    I am getting an error message that Spoon cannot connect to an Oracle Service. This is really strange since I connect to Oracle DBs all the time via SID and Service with native JDBC connection. This particular service seems to give Spoon an issue. I know that Matt C. has a great love of Oracle's SQLNet connection scheme, but I am hoping someone else may have seen this.

    Error connecting to database [CPL QA3] : org.pentaho.di.core.exception.KettleDatabaseException:
    Error occured while trying to connect to the database

    Error connecting to database: (using class oracle.jdbc.driver.OracleDriver)
    Listener refused the connection with the following error:
    ORA-12505, TNS:listener does not currently know of SID given in connect descriptor
    The Connection descriptor used by the client was:

    Error occured while trying to connect to the database

    I can connect to the database service with SQL Developer and TOAD and with Informatica using the same connection information. I am using 3.2.0-GA on MacOS and Oracle 10.2 on a remote server. I have not tried OCI. The definition of TAF is a Service not the SID.

    For grins, I pulled the latest 4.0 build and got the same error.

    Any thoughts?

    Bill W.

  2. #2


    When this happened to me, was the name of the database wrong. Try another name and try other Oracle databases if possible. Probably one of the three parameters is wrong: the database name, hostname or port number.

  3. #3
    pstoellberger Guest


    well it does say in the error "listener does not currently know of SID given in connect descriptor" - so TAF is not your correct SID

    i think you can see the available SID's on the remote machine with something like "/etc/init.d/oracle status"

  4. #4


    Actually, I can connect from other tools with the same connection information. TAF is not the SID it is the service name. I use service names in other Spoon connections without any problems. The TNS Listener should be just looking for a valid name and the SID or service name should work. So, I know the connection is good, and I know that services as well as SID naming conventions work through the JDBC connector so this is baffling.

    The only thought I had was maybe the way the JDBC driver works (not Spoon issue). The Oracle thin connector uses serverort/service for service connections and serverort:SID for SID connections. Just reaching here. I did try to put 1521/TAF in the port field and left the SID blank, just as a test. But that did not work.

    So, I am not sure where the issue is. It is baffling that this server is the only one I have a problem connecting. BTW, the TNS entry is a bit different than others:

    (ADDRESS = (PROTOCOL = TCP)(HOST = = 1521))
    (ADDRESS = (PROTOCOL = TCP)(HOST = = 1521))
    (LOAD_BALANCE = yes)
    (RETRIES = 180)
    (DELAY = 5)

    Maybe, I should use

    The responses are appreciated. Thanks.


  5. #5
    pstoellberger Guest


    Yeah, i'd suggest trying TAF.WORLD as SID

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.