Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: action sequence failing on complex parameters

  1. #1
    Join Date
    Aug 2009
    Posts
    4

    Post action sequence failing on complex parameters

    I am encountering a problem with reports using Pentaho BI server 3.0.0.

    I'm trying to publish reports that use list parameters. Using the report designer, I can publish the report to the server and it works fine. However, via the report designer, I can only add parameters that require the user to manually type something in.

    So what I've been doing is publishing the report to my desktop with no parameters to obtain the xml and xaction files. Then, via the report designer, I publish the report to the server. Then I take the xaction file published to my desktop and open it with Pentaho Design Studio. I use design studio to add a parameter that takes its input from a list (Freshman, Sophomore, Junior, Senior). This results in the attached xaction file, which I then manually copy out to the server and then update the solution repository via the administrative console.

    But when I try to run the report, the parameter screen comes up correctly, I enter the parameters, and then I get the following error message:

    Error: SolutionEngine.ERROR_0007 - Action sequence execution failed (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: Starting execute of QSIS//Student%20Roster.xaction (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: Getting runtime context and data (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: Loading action sequence definition file (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Error: SolutionEngine.ERROR_0007 - Action sequence execution failed (org.pentaho.platform.engine.services.solution.SolutionEngine)

    I have checked the server logs, and they provide no additional detail. It can't be the encoding on the xaction file. I know the reporting engine can read the file, because it correctly displays the parameter screen. I know the query works, because it's been tested against the underlying database.

    I have searched the forums for similar problems already. I've tried the solutions suggested there to no avail. This error seems unique because the ERROR_0007 message is the most level of detail that Pentaho gives.

    I've also tried comparing my own xaction file with some of the examples that come with pentaho. I can't find any substantive difference.

    BTW, I know that the actual query is missing in the attached xaction (replaced by "..."). I had to take it out before I posted this.

    Any help on this issue would be greatly appreciated!
    Attached Files Attached Files

  2. #2

    Default

    hello,

    Have you tried to remove the quotation mark in the where clause??

    i want to say, replace this sentence

    ss.SEMESTER_ID = '{PREPARE:ENTER_SEMESTER}' AND TO_CHAR(cl.CLASS_ID) = '{PREPARE:CLASS_SELECTED}'

    for this one:

    ss.SEMESTER_ID = {PREPARE:ENTER_SEMESTER} AND TO_CHAR(cl.CLASS_ID) = {PREPARE:CLASS_SELECTED}

    I hope it works.

    Regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.