Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: design and generate report using xml datasourc

  1. #1
    Join Date
    Aug 2007
    Posts
    198

    Default design and generate report using xml datasourc

    Hi,
    I have data in xml as follows
    <root>
    <emp>
    <id>1</id>
    <name>xx</name>
    </emp>
    <emp>
    <id>2</id>
    <name>yy</name>
    </emp>
    </root>

    1. I need to design report, publish , generate report using the xml data.
    any one can help me regarding this with step by step procedure.(ie how design , publish and generate report using report designer and bi-server)

    2. i have to display report based on id also.

  2. #2
    Join Date
    Aug 2007
    Posts
    198

    Default Error while generating report using Xquery

    I designed report using xquery. while lookig into preview in report designer i am able to get report. I published same report in to server, while generating the report the following error is displaying on browser.

    Failed Error: RuntimeContext.ERROR_0012 - ActionDefinition for XQueryLookupRule did not execute successfully (org.pentaho.platform.engine.services.runtime.RuntimeContext) Debug: Starting execute of xmlreports//TestReport.xaction (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: Getting runtime context and data (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: Loading action sequence definition file (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: audit: instanceId=3375c3e3-8d41-11de-8c9a-f994d80aba4f, objectId=org.pentaho.platform.engine.services.runtime.RuntimeContext, messageType=action_sequence_start (org.pentaho.platform.engine.services.runtime.RuntimeContext)
    Error: RuntimeContext.ERROR_0012 - ActionDefinition for XQueryLookupRule did not execute successfully (org.pentaho.platform.engine.services.runtime.RuntimeContext)
    Error: SolutionEngine.ERROR_0007 - Action sequence execution failed (org.pentaho.platform.engine.services.solution.SolutionEngine)


    Server Version: Pentaho Platform Engine Core 3.0.0-STABLE.37736


    I attached my xml,xaction please help how to get the report using xml data using xquery.
    Attached Files Attached Files

  3. #3
    Join Date
    Aug 2007
    Posts
    198

    Default Error while generating report using Xquery

    The problem may be with xml data, I solved this by adding <result-set>and<row> elements
    <?xml version="1.0" encoding="UTF-8"?>
    <result-set><!--java.lang.String,java.lang.String,java.lang.String,java.math.BigDecimal,java.math.BigDecimal,java.math.BigDecimal-->
    <row>
    <emp>
    <id>1</id>
    <name>sreenath</name>
    </emp>
    </row>
    <row>
    <emp>
    <id>2</id>
    <name>ram</name>
    </emp>
    </row>
    </result-set>

  4. #4

    Default

    if u want to display base upon id then use following query

    /row/emp[id='{PREPARELATER:id}']/name


    this query will give u result based upon id

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.