Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Last minute please someone knows whats going on....

  1. #1

    Default Last minute please someone knows whats going on....

    Right presentation at 10am and I've created a couple of MDX reports today that are knackered, work fine in PRD and are just broken in BI Server,
    I'm running postgres, BI Server 3.stable, PRD 3.0RC(the latest 3.0 Report designer just comes out with weird mondrian failure messages even though there isn't anything wrong)

    Here is the query:
    Code:
    select NON EMPTY {[Measures].[Amount]} ON COLUMNS,
      NON EMPTY Filter(((([Users].Children * [Projects].Children)) * [Type].Children), ([Measures].[Amount] > 0.0)) ON ROWS
    from [ProjandPack]
    where [Sub Contractor].[All Sub Contractors].[NULL]
    Its like its changed column names or something(guessing)?

    Suggestions welcome

    Cheers

    Tom
    Attached Images Attached Images   
    Attached Files Attached Files
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  2. #2
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    First guess: The column naming change that broke so many of the existing reports.

    PRD-3.0 does assume the column names are computed in the old way, while the platform introduced a new column-name algorithm for its MDX datasources. There is a flag you can set to force it to be the old mode.
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  3. #3
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  4. #4

    Default

    Now see you got me with that one before, I even blogged it, but not to not believe you Taqua I pasted the thing into my xaction, and now I get nothing at all apart from blank lines.....

    Anyway the thing was already in pentahoObjects
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  5. #5

    Default

    ok well changing the property in pentahoObjects makes no difference at all, and adding it to the xaction gives me blank lines.
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.