Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Turning debug SQL logging in platform 3.5 for adhoc?

  1. #1
    Join Date
    Apr 2007
    Posts
    2,009

    Default Turning debug SQL logging in platform 3.5 for adhoc?

    Hi,

    Previously i could add this:

    <category name="org.pentaho.plugin.sql">
    <priority value="DEBUG"/>
    </category>

    <category name="org.pentaho.platform.plugin.action.pentahometadata">
    <priority value="DEBUG" />
    <appender-ref ref="PENTAHOFILE"/>
    <appender-ref ref="PENTAHOCONSOLE"/>
    </category>

    To log the sql generated by adhoc.

    This no longer seems to work. Does anyone know what the settings are?

    I have a problem with the queries being generated so want to track it down and see why it's changed since 1.7.

    Thanks,
    Dan

  2. #2
    Join Date
    Apr 2007
    Posts
    2,009

    Default

    Anyone?

    I have a problem with the platform not being backwards compatible - i'd have thought this would be an important issue to debug and resolve whilst in RC status?

    I understand platform 3.5 is not yet covered under support so can't post my question there.

    Dan

  3. #3
    Join Date
    Apr 2007
    Posts
    2,009

    Default

    Ok, if you put org.pentaho to DEBUG logging, you see the SQL. I guess the class names that log the sql have changed, so the old settings have changed, and im not sure what they've changed to.

    The platform also grinds to a halt due to quantity of logs, but hey ho

    Anyway i got to the bottom of my issue, and raised another post here:

    http://forums.pentaho.org/showthread.php?p=221348

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.