Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: 3.5 RC2 upgrade - cant authenticate with any users

  1. #1
    Join Date
    May 2009
    Posts
    9

    Default 3.5 RC2 upgrade - cant authenticate with any users

    Hi there,
    I just upgraded to 3.5 RC2 for bi-server and i recreated all my users in the administration console. I cannot log into pentaho with any of them. I just recieve a message says "Authentication Failed".

    Thoughts? Points in a good direction?

    TIA,
    Kirby

  2. #2
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    Try clearing your browser's cache/cookies.
    (en) Path to Pentaho knowledge: (1:Search the Wiki > 2:Search the Forums > 3:Ask) or (1:Get a Subscription)
    (es) El camino al conocimiento en Pentaho: (1:Buscar en la Wiki > 2:Buscar en los Foros > 3:Preguntar) o (1:Comprar una Subscripción)

  3. #3
    Join Date
    May 2009
    Posts
    9

    Default

    well that's embarrasing.

    thank you.

  4. #4
    Join Date
    Mar 2009
    Posts
    15

    Default

    Hi,

    I'm the same problem, but nothing to do !

    I use Pentaho 3.5 RC2 with MySQL.

    What can i do ?

    Thanks

  5. #5
    Join Date
    Apr 2007
    Posts
    2,009

    Default

    i've just had this problem in ci too.

    What seems to happen is that this fires:

    11:03:35,889 ERROR [SecurityStartupFilter] getAttribute: Session already invalidated
    java.lang.IllegalStateException: getAttribute: Session already invalidated
    at org.apache.catalina.session.StandardSession.getAttribute(StandardSession.java:1021)

    And it doesnt let you log in, it's a bug.

    I think if your session times out, and you are at the login page, and try to login again, thats when it breaks.

    Worth a jira i think. but im not sure how reproducible it is?

  6. #6

    Exclamation I also can't authenticate

    Installed RC2. Joe logs in to the User Console, but he can't seem to access any content. He can't log in to the admin console with the password 'password'.

    The users I created under RC1 can't log in at all. I just get
    AUTH FAILURE: user joe
    in stderr.

    Once Joe's logged in to the user console, he can't access any content. What log should I be looking in?

  7. #7

    Exclamation Nor through the Report Designer

    Quote Originally Posted by ionFreeman View Post
    Installed RC2. Joe logs in to the User Console, but he can't seem to access any content. He can't log in to the admin console with the password 'password'.

    The users I created under RC1 can't log in at all. I just get
    AUTH FAILURE: user joe
    in stderr.

    Once Joe's logged in to the user console, he can't access any content. What log should I be looking in?
    I should point out I also can't log in from the Pentaho Report Designer 3.5 RC2

  8. #8
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    Quote Originally Posted by ionFreeman View Post
    ... He can't log in to the admin console with the password 'password'...
    There's no joe user in the admin console. Just admin (by default).
    (en) Path to Pentaho knowledge: (1:Search the Wiki > 2:Search the Forums > 3:Ask) or (1:Get a Subscription)
    (es) El camino al conocimiento en Pentaho: (1:Buscar en la Wiki > 2:Buscar en los Foros > 3:Preguntar) o (1:Comprar una Subscripción)

  9. #9

    Red face I think my core issue is that my users didn't survive the upgrade

    I'd just been working as admin in Kettle and didn't notice.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.