Hitachi Vantara Pentaho Community Forums
Results 1 to 11 of 11

Thread: Problemas al actualizar la consola del pentaho

  1. #1

    Default Problemas al actualizar la consola del pentaho

    Buenos dia, alguien me puede decir como hago para actualizar mi pentaho ya que al actualizarlo me saca el error de Repository cache refresh failed, antes solucionaba este problema deslogeandome y volviendo a entrar a la consola pero ahora aun haciendo esto me sigue sacando el mismo error
    he visto que el log de errores me saca el siguiente error:

    2009-09-02 08:38:17,032 ERROR [org.pentaho.platform.util.logging.Logger] Error end:
    2009-09-02 08:38:17,032 ERROR [org.pentaho.platform.util.logging.Logger] Error end:

    me podrian ayudar porfa
    muchas gracias por su atencion prestada

  2. #2
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    ¿Qué versión de la plataforma estás usando?

    Pregunta básica, pero obligatoria: ¿probaste reiniciar el servidor?

    ¡Saludos!
    (en) Path to Pentaho knowledge: (1:Search the Wiki > 2:Search the Forums > 3:Ask) or (1:Get a Subscription)
    (es) El camino al conocimiento en Pentaho: (1:Buscar en la Wiki > 2:Buscar en los Foros > 3:Preguntar) o (1:Comprar una Subscripción)

  3. #3

    Default

    Hola gracias por responderme, la version de mi pentaho es 2.0 y ya he probado reiniciando el servicio del pentaho, parandolo y volviendolo a subir, también he probado reiniciando el equipo y aun me sigue sacando el mismo error: Repository cache refresh failed y ya no se que hacerle.

  4. #4
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    Qué extraño. Aparentemente le ha pasado a varios usuarios, pero no se ha publicado ninguna solución. Voy a intentar replicar el error con la v2.0 a ver si lo logro.
    (en) Path to Pentaho knowledge: (1:Search the Wiki > 2:Search the Forums > 3:Ask) or (1:Get a Subscription)
    (es) El camino al conocimiento en Pentaho: (1:Buscar en la Wiki > 2:Buscar en los Foros > 3:Preguntar) o (1:Comprar una Subscripción)

  5. #5

    Default

    buen dia tdidomenico al parecer creo saber el motivo de porque no me quiere actualizar el contenido de mi pentaho en la consola, pero no se como solucionarlo, he borrado muchos de mis reportes que tengo publicados en mi pentaho y me carga el contenido perfectamente aunque un poco demorado porque aun quedan muchos publicados, pero en el momento de añadir mas reportes se pone lento y me saca el error "Repository cache refresh failed" o se queda cargando y se bloquea no se podre ampliar la capacidad de almacenaje del pentaho o de mis reportes ya que el contenido de ellos pesa 225 MB ¿si se puede hacer podrías indicarme como? . espero que esto les sirva para ayudar a solucionar mi problema por favor
    muchas gracias por la atención prestada.

  6. #6
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    ¿225MB? Me imagino que eso será una vez que generaste los reportes, y no el tamaño de la carpeta de solución...

    ¿Estás publicando todos los reportes a una única carpeta? Si fuera así, yo probaría distribuirlos en diferentes carpetas, ó inclusive en diferentes soluciones, a ver si mejora.

    ¡Saludos!
    (en) Path to Pentaho knowledge: (1:Search the Wiki > 2:Search the Forums > 3:Ask) or (1:Get a Subscription)
    (es) El camino al conocimiento en Pentaho: (1:Buscar en la Wiki > 2:Buscar en los Foros > 3:Preguntar) o (1:Comprar una Subscripción)

  7. #7

    Default

    Hola tdidomenico, el tamaño es solo de los reportes y no de la solución completa y los reportes ya están publicados todos en mi pentaho estos los tengo todos distribuidos en carpetas ya que como manejo varios clientes cada cliente maneja su carpeta con sus respectivos reportes. en mi ensayo anterior si quito las carpetas de reportes de ciertos clientes y actualizo el pentaho me actualiza correctamente pero un poco lento porque dejo reportes de otros clientes. y si vuelvo y añado los reportes de los clientes que borre anteriormente no me actualiza me saca el mensaje: "Repository cache refresh failed" por eso me parece raro que con pocos reportes actualice bien pero con muchos no actualice, aunque todos estos reportes están todos en la carpeta (pentaho-solutions) no se si podre crear otra solución y no dañe el pentaho si es así ¿me puedes decir por favor como la creo? y si la creo quedaría el nombre (pentaho-solutions2)
    gracias por responder mi preguntan.

  8. #8
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    En realidad me refería a subcarpetas de pentaho-solutions, no a crear una alternativa a ésta.

    Leí en otros hilos que a veces apareció este problema al desarrollar en diferentes ambientes, ya que el motor se confundía con las fechas de los archivos. ¿Siempre probaste quitar las mismas carpetas? Pregunto esto porque quizá haya ciertas carpetas/reportes que son las culpables del error. Si es así, sería bueno identificarlas.

    Si esto no es así, no queda otra que asumir que la plataforma está teniendo problemas para manejar gran cantidad de reportes. En ese caso te sugeriría probar con una instalación de la 3.5RC2 y ver qué ocurre.
    (en) Path to Pentaho knowledge: (1:Search the Wiki > 2:Search the Forums > 3:Ask) or (1:Get a Subscription)
    (es) El camino al conocimiento en Pentaho: (1:Buscar en la Wiki > 2:Buscar en los Foros > 3:Preguntar) o (1:Comprar una Subscripción)

  9. #9

    Default

    Buen dia tdidomenico he instalado el pentaho 3.0 y he ensayado todos mis reportes en este, y los actualiza bien, pero ahora tengo un problema al quitarle la seguridad al pentaho 3.0 he intentado quitandosela como lo hacia en el pentaho 2.0 con la guia del siguiente link: http://wiki.pentaho.com/display/Serv...oving+Security
    pero me saca un error al iniciar el pentaho que dice:
    Pentaho Initialization Exception

    The following errors were detected
    [es_49] One or more system listeners failed. These are set in the systemListeners.xml.
    PentahoSystem.ERROR_0014 - Error mientras se intentaba ejecutar la secuencia de arranque por org.pentaho.platform.plugin.services.pluginmgr.PluginAdapter

    Please see the server console for more details on each error detected.

    y en el log de errores me saca el siguiente error:

    Caused by: org.pentaho.platform.api.engine.PentahoSystemException: PentahoSystem.ERROR_0014 - Error mientras se intentaba ejecutar la secuencia de arranque por org.pentaho.platform.plugin.services.pluginmgr.PluginAdapter
    at org.pentaho.platform.engine.core.system.PentahoSystem.notifySystemListenersOfStartup(PentahoSystem.java:302)
    ... 27 more
    2009-09-10 09:34:31,390 ERROR [org.pentaho.platform.util.logging.Logger] misc-org.pentaho.platform.engine.core.system.PentahoSystem: PentahoSystem.ERROR_0014 - Error mientras se intentaba ejecutar la secuencia de arranque por org.pentaho.platform.plugin.services.pluginmgr.PluginAdapter
    org.pentaho.platform.api.engine.PentahoSystemException: PentahoSystem.ERROR_0014 - Error mientras se intentaba ejecutar la secuencia de arranque por org.pentaho.platform.plugin.services.pluginmgr.PluginAdapter
    at org.pentaho.platform.engine.core.system.PentahoSystem.notifySystemListenersOfStartup(PentahoSystem.java:306)


    Caused by: org.pentaho.platform.api.engine.PentahoSystemException: PentahoSystem.ERROR_0014 - Error mientras se intentaba ejecutar la secuencia de arranque por org.pentaho.platform.plugin.services.pluginmgr.PluginAdapter
    at org.pentaho.platform.engine.core.system.PentahoSystem.notifySystemListenersOfStartup(PentahoSystem.java:302)
    ... 27 more
    2009-09-10 09:34:31,390 ERROR [org.pentaho.platform.util.logging.Logger] Error end:
    2009-09-10 09:34:31,390 ERROR [org.pentaho.platform.util.logging.Logger] Error end:
    2009-09-10 10:24:41,140 WARN [org.pentaho.platform.util.logging.Logger] misc-org.pentaho.platform.engine.core.system.PentahoSystem: PentahoSystem.WARN_OBJECT_NOT_CONFIGURED - Object with name "IPluginManager" has not been configured in the Pentaho object factory.
    2009-09-10 10:24:41,140 WARN [org.pentaho.platform.util.logging.Logger] misc-org.pentaho.platform.engine.core.system.PentahoSystem: PentahoSystem.WARN_OBJECT_NOT_CONFIGURED - Object with name "IPluginManager" has not been configured in the Pentaho object factory.


    me puedes por favor indicar como hago para quitarle la seguridad al pentaho 3.0
    muchas gracias porla atencion prestada

  10. #10
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    Acabo de aplicar lo que dice ese mismo link sobre la plataforma 3.0 y me funcionó perfectamente.

    Te adjunto los tres archivos que hay que modificar, tal cual me funcionaron correctamente a mí. Recordá también ejecutar los pasos listados en http://wiki.pentaho.com/display/Serv...ng+Default+ACL

    ¡Saludos!
    Attached Files Attached Files
    (en) Path to Pentaho knowledge: (1:Search the Wiki > 2:Search the Forums > 3:Ask) or (1:Get a Subscription)
    (es) El camino al conocimiento en Pentaho: (1:Buscar en la Wiki > 2:Buscar en los Foros > 3:Preguntar) o (1:Comprar una Subscripción)

  11. #11

    Default

    Hola tdidomenico Mucha gracias por todo, Me ha funcionado excelentemente, una vez mas me ha salvado.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.