Hitachi Vantara Pentaho Community Forums
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: PRPT Report Burst

  1. #1

    Default PRPT Report Burst

    Hello,

    I just started playing with the 3.5ceRC2 server and the latest tools that go along with it. There has been a lot of changes since I started working with 1.6ce and I was hoping if someone could assist.

    I am attempting to burst a .prpt report using an xaction. I have successfully setup the server for email capability, but when I attach the report I receive this error:

    Code:
    Error: RuntimeContext.ERROR_0021 - Invalid output  parameter "outputstream" requested during execution of  lining_efficiency_report_burst.xaction  (org.pentaho.platform.engine.services.runtime.RuntimeContext) Debug: Starting execute of  plant-minder/burst_xactions/lining_efficiency_report_burst.xaction  (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: Getting  runtime context and data  (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: Loading  action sequence definition file  (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: audit:  instanceId=d67a34c6-9d49-11de-85d2-435c74981b84,  objectId=org.pentaho.platform.engine.services.runtime.RuntimeContext,  messageType=action_sequence_start  (org.pentaho.platform.engine.services.runtime.RuntimeContext)
    Error:  RuntimeContext.ERROR_0021 - Invalid output parameter "outputstream" requested  during execution of lining_efficiency_report_burst.xaction  (org.pentaho.platform.engine.services.runtime.RuntimeContext)
    Error:  Base.ERROR_0002 - Component execution failed  (org.pentaho.platform.engine.services.solution.PojoComponent)
    Error:  RuntimeContext.ERROR_0012 - ActionDefinition for SimpleReportingComponent did  not execute successfully  (org.pentaho.platform.engine.services.runtime.RuntimeContext)
    Error:  SolutionEngine.ERROR_0007 - Action sequence execution failed  (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Any suggestions would be greatly appreciated.
    The best thing about a boolean is even if you are wrong, you are only off by a bit.
    Anonymous

  2. #2
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    Have you declared your output stream in the XAction "action-outputs" section?
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  3. #3
    Join Date
    Mar 2009
    Posts
    15

    Default

    Hi,

    I have the same problem when i want integrate prpt in design studio.
    Yes, my <action-outputs> is good.

    What is the problem ?

    Design Studio 3.5 RC2

    Thanks

  4. #4

    Default

    Well I rebuilt the xaction, with only the report generated and then emailed. I end up with the following error:

    Code:
    Error: SolutionEngine.ERROR_0007 - Action sequence  execution failed  (org.pentaho.platform.engine.services.solution.SolutionEngine) Debug: Starting execute of plant-minder/burst_xactions/burst_test.xaction  (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: Getting  runtime context and data  (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: Loading  action sequence definition file  (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Error:  SolutionEngine.ERROR_0007 - Action sequence execution failed  (org.pentaho.platform.engine.services.solution.SolutionEngine)
    I've also attached the xaction and prpt files, in case that would help....
    Attached Files Attached Files
    The best thing about a boolean is even if you are wrong, you are only off by a bit.
    Anonymous

  5. #5

    Default

    I've not been able to make any headway with this so I figured I'd give the thread a bump.

    Any assistance will be appreciated, thanks!

    *UPDATE*

    I think this may actually be a bug. I found a bug report in JIRA that describes the same type of problem:

    http://jira.pentaho.com/browse/BISER...s:all-tabpanel

    Hopefully once it gets resolved this issue will go away....
    Last edited by DBA_Alex; 09-10-2009 at 03:00 PM.
    The best thing about a boolean is even if you are wrong, you are only off by a bit.
    Anonymous

  6. #6

    Post Pentaho Reporting Component

    DBA Alex,
    SimpleReportingComponent is not on the pallet in the Design Studio that I can see. I'm trying to get a simple parameterized report to run in an xaction, and failing, but I'm doing it with the JFreeReportComponent (add/report/Pentaho Report).
    Your xaction didn't even load in Eclipse. When I pasted in your report and email components, updated my outputs as per the thread referenced in the bug report you note and so forth, I reproduced your errors.
    Ion

  7. #7

    Default

    What version of the Design Studio are you using? I upgraded to the latest version of the eclipse plugins (3.5RC1) when I started working with the new server.
    The best thing about a boolean is even if you are wrong, you are only off by a bit.
    Anonymous

  8. #8

    Default Community Edition

    pds-ce-3.5.0-RC2.zip

  9. #9

    Default

    The SimpleReportingComponent is called the Pentaho Report Process Actions. This is available in both the PDS-CE-3.5.0-RC2 and in the eclipse plugin.

    Running a sample similar to the one I attached results in the following error:
    Code:
    Error: Base.ERROR_0002 - Component execution failed -  java.lang.NullPointerException  (org.pentaho.platform.engine.services.solution.PojoComponent) Debug: Starting execute of plant-minder/burst_xactions/burst_test.xaction  (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: Getting  runtime context and data  (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: Loading  action sequence definition file  (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: audit:  instanceId=5dc208f8-a2f8-11de-b34c-357d00bf4078,  objectId=org.pentaho.platform.engine.services.runtime.RuntimeContext,  messageType=action_sequence_start  (org.pentaho.platform.engine.services.runtime.RuntimeContext)
    Error:  Base.ERROR_0002 - Component execution failed - java.lang.NullPointerException  (org.pentaho.platform.engine.services.solution.PojoComponent)
    Error:  RuntimeContext.ERROR_0012 - ActionDefinition for SimpleReportingComponent did  not execute successfully  (org.pentaho.platform.engine.services.runtime.RuntimeContext)
    Error:  SolutionEngine.ERROR_0007 - Action sequence execution failed  (org.pentaho.platform.engine.services.solution.SolutionEngine)
    This is also taking into account the thread associated with that bug report:

    http://forums.pentaho.org/showthread...442#post222442
    The best thing about a boolean is even if you are wrong, you are only off by a bit.
    Anonymous

  10. #10

    Wink JFreeReportComponent

    That's odd. As I said below, clicking add, reports, Pentaho report gives me a JFreeReportComponent.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.