Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Email.ERROR_0011 - NullPointerException

  1. #1

    Default Email.ERROR_0011 - NullPointerException

    Hi,

    i've created an XAction, using the SimpleReportingComponent and want to send the Result via eMail to me.

    The XML-Source of the XAction is the following:

    --------------------------------------------------------------------------
    <?xml version="1.0" encoding="UTF-8"?>
    <action-sequence>
    <title>Testreport</title>
    <version>1</version>
    <logging-level>ERROR</logging-level>
    <documentation>
    <author/>
    <description>Empty blank action sequence document</description>
    <help/>
    <result-type/>
    <icon/>
    </documentation>

    <inputs/>

    <outputs>
    <outputstream type="content">
    <destinations>
    <file>content</file>
    </destinations>
    </outputstream>
    </outputs>

    <resources>
    <report-definition>
    <solution-file>
    <location>Testreport.prpt</location>
    <mime-type>application/zip</mime-type>
    </solution-file>
    </report-definition>
    </resources>

    <actions>
    <action-definition>
    <component-name>SimpleReportingComponent</component-name>
    <action-type>Pentaho Report</action-type>
    <action-outputs>
    <outputstream type="content"/>
    </action-outputs>
    <component-definition>
    <outputType><![CDATA[application/pdf]]></outputType>
    </component-definition>
    </action-definition>

    <action-definition>
    <component-name>TemplateComponent</component-name>
    <action-type>attachment name</action-type>
    <action-inputs/>
    <action-outputs>
    <output-message type="string" mapping="attach_name"/>
    </action-outputs>
    <component-definition>
    <template><![CDATA[test.pdf]]></template>
    </component-definition>
    </action-definition>

    <action-definition>
    <component-name>EmailComponent</component-name>
    <action-type>E-Mail</action-type>
    <action-inputs>
    <outputstream type="content"/>
    <attach_name_1 type="string" mapping="attach_name"/>
    </action-inputs>
    <component-definition>
    <to><![CDATA[michael.mest@<host>.de]]></to>
    <from><![CDATA[db2_ae@<host>.de]]></from>
    <subject><![CDATA[Testnachriucht]]></subject>
    <message-plain><![CDATA[Dies ist nur eine Testnachricht]]></message-plain>
    <attachment-ref name-param="attach_name_1" input-param="outputstream"/>
    </component-definition>
    </action-definition>

    </actions>
    </action-sequence>
    -----------------------------------------------------------------------

    Unfortunately, i get the following error-message:

    Fehler: Email.ERROR_0011 - SMTP senden schlug fehl: michael.mest@<host>.de - java.lang.NullPointerException (org.pentaho.platform.plugin.action.builtin.EmailComponent)Debug: Konto/Allgemein/testreport.xaction wird ausgeführt (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: Hole Runtime Context und Daten. (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: LAde Actionsequenz Definitionsdatei (org.pentaho.platform.engine.services.solution.SolutionEngine)
    Debug: audit: instanceId=47cb3c29-a10a-11de-8c25-83cd1dee9b0a, objectId=org.pentaho.platform.engine.services.runtime.RuntimeContext, messageType=action_sequence_start (org.pentaho.platform.engine.services.runtime.RuntimeContext)
    Fehler: Email.ERROR_0011 - SMTP senden schlug fehl: michael.mest@<host>.de - java.lang.NullPointerException (org.pentaho.platform.plugin.action.builtin.EmailComponent)
    Fehler: RuntimeContext.ERROR_0012 - Die ActionDefinition für EmailComponent wurde nicht erfolgreich ausgefürht. (org.pentaho.platform.engine.services.runtime.RuntimeContext)
    Fehler: SolutionEngine.ERROR_0007 - Fehler beim Ausführen der Actionsequenz (org.pentaho.platform.engine.services.solution.SolutionEngine)



    I've uploaded the Report- and XActionfile as attachment.

    I cannot find the fault in the XAction. Can anyone point me into the right direction?
    Attached Files Attached Files
    Last edited by michael.mest; 12-03-2009 at 06:52 AM.

  2. #2

    Default

    Is there nobody who can help me?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.