Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Hide prpt in PUC?

  1. #1
    Join Date
    Apr 2007
    Posts
    2,010

    Default Hide prpt in PUC?

    Hi,

    If you have both a prpt and an xaction which calls the prpt, then both are displayed in PUC. How do you hide just the prpt?

    Thanks,
    Dan

  2. #2
    Join Date
    Dec 2005
    Posts
    531

    Default

    Putting it in a folder and hiding the folder usually works, that way the user can still have the right to execute the prpt e.g. from dashboards or xactions but can not reach it in PUC.

  3. #3
    Join Date
    Apr 2007
    Posts
    2,010

    Default

    there's a flaw with this good idea - if you hide the prpt subdirectory, then you can no longer publish to that folder. doh!

    This whole thing prpt/xaction hasnt been thought out at all.

  4. #4
    Join Date
    Dec 2005
    Posts
    531

    Default

    Can't you use an admin user to publish?

    I have not tried it, but if you disable the prpt subdirectory for your user's role only, an admin user should still be able ro publish.

  5. #5
    Join Date
    Apr 2007
    Posts
    2,010

    Default

    i am an admin when publishing!

    Ah; You're talking about doing it with permissions; I'd just used the hidden=true flag on the folders properties. i'll try with permissions then..

  6. #6
    Join Date
    Dec 2005
    Posts
    531

    Default

    Right...sorry if I wasn't clear enough.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.