Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Missing national characters

  1. #1
    Join Date
    Apr 2009
    Posts
    12

    Default Missing national characters

    Hi,

    I'm currently using Pentaho 3.5 on a linux distrib, but every reports I made on my own computer has a problem when it's deployed to the server.
    The problem is mentioned several times on this forum (national characters are missing when report is exported to PDF), but I couldn't solve it by changing the appropriate setting in the xml file to UTF (actually it is already set to UTF)

    Is there any other solution to make the PDF reports work? My locale is Hungarian (hu_HU)

    Thanks!

  2. #2
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    Make sure your report is configured to export text as UTF-8. (This has nothing to do with the encoding of the XML file.)

    To do that, set the configuration property

    org.pentaho.reporting.engine.classic.core.modules.output.pageable.pdf.Encoding

    to UTF-8. Also make sure that your fonts support the characters you want to export. Do not use the built-in fonts "Serif", "SansSerif" or "Monospaced", as these fonts will be mapped into the PDF fonts "Times", "Helvetica" and "Courier". None of these fonts support anything other than good old Western-European characters. (In 1985 when the Postscript standard was made, only little was known about foreign countries or cultures and no one could have foreseen that those other countries aquire computer without adopting English at the same time. )
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  3. #3
    Join Date
    Apr 2009
    Posts
    12

    Default

    Quote Originally Posted by Taqua View Post
    Make sure your report is configured to export text as UTF-8. (This has nothing to do with the encoding of the XML file.)

    To do that, set the configuration property

    org.pentaho.reporting.engine.classic.core.modules.output.pageable.pdf.Encoding

    to UTF-8. Also make sure that your fonts support the characters you want to export. Do not use the built-in fonts "Serif", "SansSerif" or "Monospaced", as these fonts will be mapped into the PDF fonts "Times", "Helvetica" and "Courier". None of these fonts support anything other than good old Western-European characters. (In 1985 when the Postscript standard was made, only little was known about foreign countries or cultures and no one could have foreseen that those other countries aquire computer without adopting English at the same time. )
    thanks for your answer! I checked both things, but I have this setting correctly set in tomcat/webapps/pentaho/WEB-INF/classes, and I use Calibri fonts everywhere. Any other idea? It would be very important to fix this since the deployment project depends on this feature :|

    In the report designer every character shows perfectly.

    Really, any help would be appreciated!

    Balazs

  4. #4
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    Well, and now the big question: Does your server have these fonts available? If it works in your PRD, then at least your report is ok. But if your server lives on a different machine, then you have to do more work.

    So:
    Did you install these fonts in the JDK's lib/fonts directory and/or your X1- server's font directory on the machine running the platform?
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  5. #5
    Join Date
    Nov 2009
    Posts
    25

    Default

    im spanish and i've to change this file for pdf

    /biserver-ce/tomcat/webapps/pentaho/WEB-INF/classes/classic-engine.properties
    the line
    org.pentaho.reporting.engine.classic.core.modules.output.pageable.pdf.Encoding=UTF-8
    and change for
    org.pentaho.reporting.engine.classic.core.modules.output.pageable.pdf.Encoding=ISO-8859-1

    hope it helps you

  6. #6
    Join Date
    Apr 2009
    Posts
    12

    Default

    Quote Originally Posted by ivazquez View Post
    im spanish and i've to change this file for pdf

    /biserver-ce/tomcat/webapps/pentaho/WEB-INF/classes/classic-engine.properties
    the line
    org.pentaho.reporting.engine.classic.core.modules.output.pageable.pdf.Encoding=UTF-8
    and change for
    org.pentaho.reporting.engine.classic.core.modules.output.pageable.pdf.Encoding=ISO-8859-1

    hope it helps you
    Thank you, this one helped me!

    I tried to find out which fonts do I have on the linux box, but it wasn't that easy since it hasnt got any X running on it, so I had to search for the java fonts which was a pain in the ass
    I also tried to change the fonts to any non-standard font, but I didn't succeed with this solution.

    Anyway, changing the encoding to ISO-8859-2 (Hungarian character set) did the job!

    balazs
    Last edited by belidzs; 01-05-2010 at 06:56 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.