Hitachi Vantara Pentaho Community Forums
Results 1 to 10 of 10

Thread: Firefox can't establish a connection to the server at localhost:8080

  1. #1

    Default Firefox can't establish a connection to the server at localhost:8080

    I apologize in advance if I'm doing something bone headed. This is my problem:

    1. I have a report prpt file I can open up in the report designer. Preview works great -- both my desktop and the development server have the required MySQL schema with identical authentication -- preview uses the local data; the database connection refers to 'localhost'.
    2. I publish it to my development server.
    3. I try to load it in the user console, and I get that message, "Firefox can't establish a connection to the server at localhost:8080."
    4. If I turn my desktop's Pentaho server, the thing loads great. If I try it from Desktop B with Desktop A (whence I published it)'s local Pentaho server running, it fails.

    It seems as if I can navigate to the report on the development server, but that the report runs from the local repository. Which is weird, and not super useful.
    (1) What could a person have done to end up in this situation?
    (2) How can he get out of it?

  2. #2

    Default

    If I go to Steel Wheels/Reporting/Order Status, for example, I'll get this error message. If I go to Steel Wheels/Dashboards/Top 10 Customers, though, I get a response (from the correct server.) So, there's some difference between reports and dashboards, and the first are hosed.

    Do I have to tell the server its own address in some configuration file to get it to refer to itself correctly when pulling reports?

  3. #3
    Join Date
    Dec 2009
    Posts
    609

    Default

    Hi Ion,

    are you able to login into the Pentaho-GUI at all and you experience the problem
    only when accessing a given report?

    If so, please check the file:
    $PENTAHO/tomcat/webapps/pentaho/WEB-INF/web.xml

    and look for this parameter:
    <param-value>http://localhost:8080/pentaho/</param-value>

    Change the "localhost" to the IP-Adress (or hostname if resolvable) of the computer
    on which Pentaho is running.
    Then restart the BI-Server and retry.

    If you cannot establish a connection to the Pentaho-GUI at all,
    check the following file:

    $PENTAHO/tomcat/conf/server.xml

    and look for this kind of setting:

    <Connector port="8080" maxHttpHeaderSize="8192"
    maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
    enableLookups="false" redirectPort="8443" acceptCount="100"
    connectionTimeout="20000" disableUploadTimeout="true" />
    <!-- Note : To disable connection timeouts, set connectionTimeout value
    to 0 -->

    The 'port="8080"' tells you, on which port the whole Pentaho-GUI should be available.

    HTH,

    Tom

  4. #4

    Default

    OK. I found this thread, which suggests changing the base-url in tomcat/webapps/pentaho/web-inf/web.xml -- I was searching by the error message

  5. #5

    Default

    That seems to work. I don't know what devilry this is, but you can't just use '/pentaho/' -- I feel like there have to be substitution variables I could use for the host and port, but then one would imagine web.xml would come like that already.

  6. #6

    Default

    Oh, hey, Tom. Thanks for helping. I missed your post until just now. I think I'm all set.

  7. #7
    Join Date
    Dec 2009
    Posts
    609

    Default

    Hi Ion,

    no problem. Important thing is: You found the reason for this problem and got Pentaho
    working for all computers (and not only the one on which Pentaho is running )

    Best regards,

    Tom

  8. #8

    Exclamation Admin Console Check User Credentials and Web Setting XML Configuration

    There's a related problem in the Admin Console -- it's also apparently pointed at my Desktop server, which explains why the solution repository wasn't refreshing.

    That's a little weird, right? I get "Unable to connect to BI Server: Check User Credentials and Web Setting XML Configuration" until I turn my Desktop server on. The browser address bar is definitely pointed at the development server.

  9. #9
    Join Date
    Jan 2006
    Posts
    245

    Default

    Add the real ipaddress of the server where the admin console resides to the TrustedIpAddress section of the Pentaho's server web.xml. The localhost address (127.0.0.1) is not enough also if the admin console is locally installed on the same server.

    Restart pentaho srv and admin console and it's done.

    Hope this help

    Regards

    Sergio

  10. #10

    Default

    Thanks for your help, Sergio -- with that tip, I found the TrustedIPAddr reference in this thread. That looks like it should have turned up when I searched on the error message, but oh, well. I don't really understand why the BI Server sees the console as its IP Address on the development server but as the loopback address 127.0.0.1 on my Desktop. Nor does this explain why my Desktop would apparently receive instructions from the admin console on the dev server. That's just weird. I'll chalk it up to Windows for now and move on.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.