Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: Pentaho 3.5 CE on Windows Server

  1. #1
    Join Date
    Jul 2009
    Posts
    25

    Default Pentaho 3.5 CE on Windows Server

    Hello,

    i have managed to install the Tomcat Windows service with the service.bat in the biserver-ce/tomcat/bin folder.

    The service is running.

    But when i try to open localhost:8080 on the server i get a message that the ressource /pentaho/ is not available.

    With the start-pentaho.bat everything works well but this method is not nice on a server because the user who started this batch job has to be logged in all the time.

    Is there something additional to do for service start or what could be wrong in my install scenario?

    Cheers

    Andre

  2. #2

    Default

    Well the first issue seems to suggest something when wrong when you unzipped the archive or something, but it should work out of the box. You can install tomcat as a service, have a google, it takes about 5 minutes to install it.

    Tom
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  3. #3
    Join Date
    Jul 2009
    Posts
    25

    Default

    The Tomcat service is not the problem. That's why i wrote "The service is running". ;-)

    But with the started Tomcat service i can't reach the Pentaho web instance.

    Why?

  4. #4

    Default

    Sorry misread that slightly, a service install shouldn't require any extra changes, check catalina.random-date or pentaho.log, and see if there are errors, it'll probably end up being something like a global var not being set as a service, but obviously not JAVA_HOME as its at least starting.

    Tom
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  5. #5

    Default

    Do you have the database running ? You have to start that manually after installing the tomcat service. Look in the data directory and start the .bat file.

    jroeterd

  6. #6

    Default

    oh yeah, forgot about hypersonic
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  7. #7
    Join Date
    Feb 2010
    Posts
    2

    Default

    Hi everyone,

    Is there any way to get the service to start hypersonic too? Because having to manually start it every time makes installing tomcat as a service quite useless. Or am I missing something here?

    Cheers.

  8. #8

    Default

    Probably, although I dunno, try google. Anyway if you are going to run Pentaho as a server you should probably switch away from hypersonic anyway.

    Tom
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  9. #9
    Join Date
    Feb 2010
    Posts
    2

    Default

    Quote Originally Posted by bugg_tb View Post
    Probably, although I dunno, try google. Anyway if you are going to run Pentaho as a server you should probably switch away from hypersonic anyway.
    Your're right, I'll look into that. Meanwhile I found this thread (didn't look hard enough before posting, apparently ) that will do the trick: http://forums.pentaho.org/showpost.p...17&postcount=4

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.