Hitachi Vantara Pentaho Community Forums
Results 1 to 7 of 7

Thread: Pentaho/Eclipse Issue...

  1. #1
    Join Date
    Jul 2009
    Posts
    7

    Default Pentaho/Eclipse Issue...

    Hello all,

    I've grabbed the latest code from svn and have also installed all the tools (their newest versions) needed to develop Pentaho under Eclipse (the newest version as well). Strangely, when I try to build the projects, it doesn't work with Ivy throwing up due to impossible resolutions. After looking at the Ivy console, I found that the properties (${dependency.pentaho-connections.revision} for example) were not being loaded. After editing the ivysettings.xml files and including a "<properties file="${ivy.settings.dir}/build.properties" />" line in all of them, things suddenly started working.

    I'm a bit confused as to why this is the case, as I would assume that if Ivy didn't work for me with the current settings, it wouldn't work for others (namely, the main Pentaho developers). What was the issue here? Was I missing something, or did that line really need to be present?

    Regards,
    J.L.Z.

  2. #2
    Join Date
    Jul 2009
    Posts
    7

    Default More problems....

    Also, it seems the repositories listed in ivy.xml don't carry all the necessary jars:

    [ivy:resolve] :: org.igniterealtime#smack;3.0.4: not found
    [ivy:resolve] :: org.quartz-scheduler#quartz;1.7.1: not found
    [ivy:resolve] :: metro#metro-webservices-api;2.0: not found
    [ivy:resolve] :: metro#metro-webservices-rt;2.0: not found

    Any ideas? What should I do?

  3. #3

    Default

    try the community build framework
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  4. #4
    Join Date
    Oct 2006
    Posts
    817

    Default

    The missing Metro JARs should be fixed now.

  5. #5
    Join Date
    Jan 2006
    Posts
    245

    Default

    J.L.Z.

    if you want to be able to build the sources from within eclipse you need to preliminary install ivyDE as detailed here http://wiki.pentaho.com/display/PEOpen/Installing+ivyDE. If you use the latest versions downloaded from apache site the process seems not to work properly and you've the problems you detailed in your post.

    Apart from that I prefer not to build the sources from within eclipse and, as bugg_tb rightly said, CBF is a good option to do that successfully.

    Regard

    S.
    Follow Me on Twitter: sramazzina
    My Skype account: sramazzina
    My Blog
    View my profile on LinkedIn: http://www.linkedin.com/in/sramazzina
    Author of Pentaho Data Integration Kitchen How-To and Pentaho Business Analytics Cookbook

    Join us on IRC server Freenode.net, channel ##pentaho ##saiku

  6. #6
    Join Date
    Oct 2006
    Posts
    817

    Default

    Regarding "org.igniterealtime#smack;3.0.4: not found," try clearing your Ivy cache by deleting ~/.ivy2/cache. (Note: This will force all JARs to be fetching from the repos again.)

  7. #7
    Join Date
    Oct 2006
    Posts
    817

    Default

    And "org.quartz-scheduler#quartz;1.7.1: not found" should now be fixed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.