Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Error while building trunk

  1. #1
    Tomas Di Domenico Guest

    Default Error while building trunk

    Greets all.

    Even though I'm up to date with the SVN revisions, I keep getting this
    error when trying to build trunk:

    ***********************
    /svnkettleroot/Kettle/trunk/src/org/pentaho/di/trans/steps/sapinput/sap/SAPConnectionFactory.java:7:
    cannot access org.pentaho.di.trans.steps.sapinput.sap.impl.SAPConnectionImpl

    bad class file:
    /svnkettleroot/Kettle/trunk/libext/ascsapjco3wrp.jar(org/pentaho/di/trans/steps/sapinput/sap/impl/SAPConnectionImpl.class)

    class file has wrong version 50.0, should be 49.0

    Please remove or make sure it appears in the correct subdirectory of the
    classpath.

    import org.pentaho.di.trans.steps.sapinput.sap.impl.SAPConnectionImpl;
    ****************

    Am I doing something wrong, or is there anything broken in the SAP step?

    Thanks in advance.

    Cheers!

    --
    You received this message because you are subscribed to the Google Groups "kettle-developers" group.
    To post to this group, send email to kettle-developers (AT) googlegroups (DOT) com.
    To unsubscribe from this group, send email to kettle-developers+unsubscribe (AT) googlegroups (DOT) com.
    For more options, visit this group at http://groups.google.com/group/kettle-developers?hl=en.

  2. #2
    Matt Casters Guest

    Default Re: Error while building trunk

    It's being resolved. For now, compile with Java 1.6.

    Matt

    On Thursday 18 March 2010 21:00:25 Tomas Di Domenico wrote:
    > Greets all.
    >
    > Even though I'm up to date with the SVN revisions, I keep getting this
    > error when trying to build trunk:
    >
    > ***********************
    > /svnkettleroot/Kettle/trunk/src/org/pentaho/di/trans/steps/sapinput/sap/SAPConnectionFactory.java:7:
    > cannot access org.pentaho.di.trans.steps.sapinput.sap.impl.SAPConnectionImpl
    >
    > bad class file:
    > /svnkettleroot/Kettle/trunk/libext/ascsapjco3wrp.jar(org/pentaho/di/trans/steps/sapinput/sap/impl/SAPConnectionImpl.class)
    >
    > class file has wrong version 50.0, should be 49.0
    >
    > Please remove or make sure it appears in the correct subdirectory of the
    > classpath.
    >
    > import org.pentaho.di.trans.steps.sapinput.sap.impl.SAPConnectionImpl;
    > ****************
    >
    > Am I doing something wrong, or is there anything broken in the SAP step?
    >
    > Thanks in advance.
    >
    > Cheers!
    >
    >


    --
    You received this message because you are subscribed to the Google Groups "kettle-developers" group.
    To post to this group, send email to kettle-developers (AT) googlegroups (DOT) com.
    To unsubscribe from this group, send email to kettle-developers+unsubscribe (AT) googlegroups (DOT) com.
    For more options, visit this group at http://groups.google.com/group/kettle-developers?hl=en.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.