Hitachi Vantara Pentaho Community Forums
Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Publicacion: ERROR

  1. #11
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    Definitivamente tenés un problema con el driver. ¿Estás seguro de que no lo tenés duplicado? Me refiero a que tengas dos versiones diferentes de jtds en diferentes directorios del Tomcat, que pudieran estar generando un conflicto a la hora de cargarlos.

    Asegurate de que sea el mismo que usás en el report designer, que sea sólo uno, y reinicia el servidor. Fijate si al hacer todo eso seguís obteniendo el mismo error.
    (en) Path to Pentaho knowledge: (1:Search the Wiki > 2:Search the Forums > 3:Ask) or (1:Get a Subscription)
    (es) El camino al conocimiento en Pentaho: (1:Buscar en la Wiki > 2:Buscar en los Foros > 3:Preguntar) o (1:Comprar una Subscripción)

  2. #12

    Default

    Ok. Mira me gustaria saber en cuales son los directorios donde debiera tener los drivers, para asi no tener los drivers duplicados. desde ya gracias. Saludos!

  3. #13
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    El directorio es "tomcat/common/lib".

    ¡Saludos!
    (en) Path to Pentaho knowledge: (1:Search the Wiki > 2:Search the Forums > 3:Ask) or (1:Get a Subscription)
    (es) El camino al conocimiento en Pentaho: (1:Buscar en la Wiki > 2:Buscar en los Foros > 3:Preguntar) o (1:Comprar una Subscripción)

  4. #14

    Default

    Buenos dias, aun sigo con este problema. Mira lei en otro foro y me dijieron que debia crear una conexion con el mismo nombre del datasource que tengo en la consola de administracion, para asi poder exportar con exito y lograr ver el reporte. Los drivers se encuentran en las carpetas correspondientes es decir biserver-ce\tomcat\common\lib de la consola de pentaho y prd-ce-3.5.0.stable\report-designer\lib\jdbc de PRD.
    Subi las dos imagenes en las cuales realize la conexion. quizas ahi tengo el error. desde ya saludos.
    Ore
    Attached Images Attached Images   
    Last edited by cristobaal; 04-13-2010 at 10:30 AM. Reason: ERROR

  5. #15
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    Creo que ya veo el problema: PRD viene por defecto con el driver JTDS para MSSQL, no con el driver de Microsoft. Y por lo que veo estás definiendo en BI Server una conexión con el driver de Microsoft.

    Tu clase del driver debería ser
    Code:
    net.sourceforge.jtds.jdbc.Driver
    y la URL
    Code:
    jdbc:jtds:sqlserver://tuservidor:1433/tubasededatos
    Creo que con eso debería andar.

    ¡Saludos!
    (en) Path to Pentaho knowledge: (1:Search the Wiki > 2:Search the Forums > 3:Ask) or (1:Get a Subscription)
    (es) El camino al conocimiento en Pentaho: (1:Buscar en la Wiki > 2:Buscar en los Foros > 3:Preguntar) o (1:Comprar una Subscripción)

  6. #16

    Default

    Entonces la clase de driver de Microsoft en la BI debiera sacarla, al igual que en driver y dejar los drivers de JTDS para ambos, es decir para PRD con driver jtds y en BI server tambien con conexion de driver jtds?

  7. #17
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    Básicamente tenés que tener el mismo driver en ambos lugares, y utilizar el mismo para la misma conexión.

    JTDS y sqlserver pueden coexistir, pero hay que tener cuidado de no utilizarlos combinados, como en tu caso.
    (en) Path to Pentaho knowledge: (1:Search the Wiki > 2:Search the Forums > 3:Ask) or (1:Get a Subscription)
    (es) El camino al conocimiento en Pentaho: (1:Buscar en la Wiki > 2:Buscar en los Foros > 3:Preguntar) o (1:Comprar una Subscripción)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.