Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Revision #13307 breaks repository import (branch 3.2.5)

  1. #1
    Benjamin Kallmann Guest

    Default Revision #13307 breaks repository import (branch 3.2.5)

    Hi Matt,

    looks like the modifications in revision #13307 due to PDI-4060 somehow
    break the repository import.

    I tried to import an XML file that created with PDI 3.2.4 into an empty
    repository using the repository explorer (Import all objects from an XML
    file). After a few directories I get an exception "Unable to create
    repository directory [Dir 1a] in directory [/Dir 1]". I did a quick
    debug approach, looks like the new method findChild does not return the
    correct child for the path to be processed.

    Could you check this please? I did not verify if the problem also exist
    in the 4.0 trunk.


    Thanks in advance,
    Ben

    --
    You received this message because you are subscribed to the Google Groups "kettle-developers" group.
    To post to this group, send email to kettle-developers (AT) googlegroups (DOT) com.
    To unsubscribe from this group, send email to kettle-developers+unsubscribe (AT) googlegroups (DOT) com.
    For more options, visit this group at http://groups.google.com/group/kettle-developers?hl=en.

  2. #2
    Matt Casters Guest

    Default Re: Revision #13307 breaks repository import (branch 3.2.5)

    There is no need to discuss this here.

    You know that you need to fIle a bug report against 3.2.5 and attach a
    repository export that breaks.

    "It doesn't" work is not helpful so attach a stack trace.

    Thanks in advance,
    Matt

    Op woensdag 9 juni 2010 01:09:11 schreef Benjamin Kallmann:
    > Hi Matt,
    >
    > looks like the modifications in revision #13307 due to PDI-4060 somehow
    > break the repository import.
    >
    > I tried to import an XML file that created with PDI 3.2.4 into an empty
    > repository using the repository explorer (Import all objects from an XML
    > file). After a few directories I get an exception "Unable to create
    > repository directory [Dir 1a] in directory [/Dir 1]". I did a quick
    > debug approach, looks like the new method findChild does not return the
    > correct child for the path to be processed.
    >
    > Could you check this please? I did not verify if the problem also exist
    > in the 4.0 trunk.
    >
    >
    > Thanks in advance,
    > Ben


    --
    You received this message because you are subscribed to the Google Groups "kettle-developers" group.
    To post to this group, send email to kettle-developers (AT) googlegroups (DOT) com.
    To unsubscribe from this group, send email to kettle-developers+unsubscribe (AT) googlegroups (DOT) com.
    For more options, visit this group at http://groups.google.com/group/kettle-developers?hl=en.

  3. #3
    Benjamin Kallmann Guest

    Default Re: Revision #13307 breaks repository import (branch 3.2.5)

    Hi Matt,

    yes, you are right - sorry about that. All done, created JIRA-4102 (http://jira.pentaho.com/browse/PDI-4102)

    Thanks,
    Ben


    -------- Original-Nachricht --------
    > Datum: Wed, 9 Jun 2010 09:21:01 +0200
    > Von: Matt Casters <mcasters (AT) pentaho (DOT) org>
    > An: kettle-developers (AT) googlegroups (DOT) com
    > Betreff: Re: Revision #13307 breaks repository import (branch 3.2.5)


    >
    > There is no need to discuss this here.
    >
    > You know that you need to fIle a bug report against 3.2.5 and attach a
    > repository export that breaks.
    >
    > "It doesn't" work is not helpful so attach a stack trace.
    >
    > Thanks in advance,
    > Matt
    >
    > Op woensdag 9 juni 2010 01:09:11 schreef Benjamin Kallmann:
    > > Hi Matt,
    > >
    > > looks like the modifications in revision #13307 due to PDI-4060 somehow
    > > break the repository import.
    > >
    > > I tried to import an XML file that created with PDI 3.2.4 into an empty
    > > repository using the repository explorer (Import all objects from an XML
    > > file). After a few directories I get an exception "Unable to create
    > > repository directory [Dir 1a] in directory [/Dir 1]". I did a quick
    > > debug approach, looks like the new method findChild does not return the
    > > correct child for the path to be processed.
    > >
    > > Could you check this please? I did not verify if the problem also exist
    > > in the 4.0 trunk.
    > >
    > >
    > > Thanks in advance,
    > > Ben

    >
    > --
    > You received this message because you are subscribed to the Google Groups
    > "kettle-developers" group.
    > To post to this group, send email to kettle-developers (AT) googlegroups (DOT) com.
    > To unsubscribe from this group, send email to
    > kettle-developers+unsubscribe (AT) googlegroups (DOT) com.
    > For more options, visit this group at
    > http://groups.google.com/group/kettle-developers?hl=en.


    --
    GRATIS f

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.