Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: This parameter value is of an invalid value

  1. #1
    Join Date
    Sep 2007
    Posts
    834

    Default This parameter value is of an invalid value

    Hi,
    I created a report (PRD 3.6) which has a Multi Value List parameter.
    In PRD the report works fine, no matter if I choose one, or more values.
    From PUC 3.6, the list of values to choose from, is headed by the error "This parameter value is of an invalid value".
    If I write the full url with values for the parameter, I have the same error.
    any clue?
    thanks!

  2. #2
    Join Date
    Jan 2011
    Posts
    3

    Default Same Issue

    I'm having the very same issue. The report works fine in Pentaho Report Designer 3.7 with the multi-value list. When I publish and load it from the PUC, the multi-value list parameter just says "This parameter value is of an invalid value" and removes my selection no matter what I click.

    The field is set as not required, type is "Object" and there's no validation against the values.

    This is very frustrating as I can no longer have parameters with multiple values.

  3. #3

    Default

    I think it is better to add validation from the design stage as it has helped me a lot. Validation during design time testing increases my confidence that I will have less of that issue at runtime.

    Secondly, when you execute a query try and find out what data type PRD has assigned to the column from the data window. Then set the parameter type to the same data type. This is how I solved such issues.

    Regards

  4. #4
    Join Date
    Jan 2011
    Posts
    3

    Default

    Thanks for the help, your advice did stop the error message from occurring when I went to "number" instead of "object" (which I thought was needed since it was an array), but unfortunately the underlying problem is still there:

    When I have a multi-value list, I click on one or more options and the browser just refreshes and clears everything out. There's no error message, but I still can't select any values. Any ideas?

  5. #5
    Join Date
    Aug 2010
    Posts
    17

    Default

    I had something like that today when I migrated from 3.6 to 3.7 pentaho's version...
    Like okmich said, It's a good aproach create a query to see what type of data the PRD thinks that parameters is.
    In my case I was doing a select * from a table with a union with something like select -1 as id, "All" as description. And I put the Number as the parameter type. It didn't work as I wanted. In the browser,
    the parameters didn't have any value despite I choose one. After creating the query, I selected as the main query in the data window inside PRD and It seems that the column was of another type: long...
    After change the type again, it started to work in the browser and all the multi-value parameters work perfectly.

    Diogo.
    Last edited by cmboy; 01-11-2011 at 01:23 PM.

  6. #6
    Join Date
    Jan 2011
    Posts
    7

    Default

    I've just had the same issue, and by playing around with the parameter data type, I finally managed to make it work.
    I was using a "year" as parameter, the year was coming from a simple SQL query (select distinct year from dimension_date) and PRD defined it automatically as OBJECT. Unfortunately once published it wasn't working anymore, even though it was fine in PRD's preview.
    I've defined the year as an integer and now it works fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.