Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Loose of filter condition in PDI 4.0.0

  1. #1

    Default Loose of filter condition in PDI 4.0.0

    Hi all,
    I'm experiencing a strange behavior while converting from 3.2.0 to 4.0.0. I tried the following operation sequence either in Windows and in Linux environment, with the same result. Follow me:

    - After 4.0.0 installation, convert existing 3.2.0 Kettle DB and connect
    - Open a transformation containig at least a 'Filter rows' step, better if it contains more than one
    - Chech the filter conditions; they seem to be correct
    - Change something in one random step, so that the transformation is changed and iit must be saved before execution
    - Execute it without saving, so that PDI runs the on flight save of the transformation
    - Close and reopen the transformation

    The problem I'm facing is that after this operations sequence the filter conditions in the 'Filter rows' steps ar ALMOST ALWAYS (NOT always) loosed.
    I don't get any execution error executing the transformation again, but the result of every lacking condition Filter rows step is always false.

    I don't see any other problems in the other steps.
    Did anyone face the same problem?
    Thanks a lot

    Andrea

  2. #2
    Join Date
    Jul 2009
    Posts
    17

    Default

    Unfortunatly this is a known issue with 4.0.0 which has been fixed in 4.0.1.
    http://forums.pentaho.com/showthread...s-with-filters
    http://jira.pentaho.com/browse/PDI-4225
    You can get 4.0.1 from a link on here:
    http://forums.pentaho.com/showthread...s-4.0.1-stable

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.