Hitachi Vantara Pentaho Community Forums
Results 1 to 15 of 15

Thread: Cannot see my cube in PAT

  1. #1

    Default Cannot see my cube in PAT

    Hello all, I have installed the Bi Agile Pluggin and publish my model in the Spoon.

    When I open the Pat in the User Console I can't choose or see the model just published.

    If I use "New Analysis View" I can see my model.

    Did I miss something?

    Thanks.

    Sebastian.

  2. #2
    Join Date
    Jan 2006
    Posts
    205

    Default

    I don't use the BI server much, so I've never tried to use a published cube schema in PAT. I just manually setup the cube in PAT.
    Is the connection in the datasources.xml file in biserver-ce\pentaho-solutions\system\olap ?

    regards,

    Mike

  3. #3

    Default

    I didn't write this bit Paul did, so I don't really know, but I do know if the magic works internally the sample cube should be autodetected on XMLA so assuming that is the case with your setup, its probably something todo with the entry in olap/datasources.xml (Assuming there is one, i dunno how agile bi works in that regard)

    Tom
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  4. #4

    Default

    The datasource is in the xml, in /pentaho-solutions/system/olap, and in the PAT, I see only two cubes Name:  PATCubes.jpg
Views: 256
Size:  26.9 KB

    <?xml version="1.0" encoding="UTF-8"?>

    <DataSources>
    <DataSource>
    <DataSourceName>Provider=Mondrian;DataSource=Pentaho</DataSourceName>
    <DataSourceDescription>Pentaho BI Platform Datasources</DataSourceDescription>
    <URL>http://localhost:8080/pentaho/Xmla?userid=joe&amp;password=password</URL>
    <DataSourceInfo>Provider=mondrian</DataSourceInfo>
    <ProviderName>PentahoXMLA</ProviderName>
    <ProviderType>MDP</ProviderType>
    <AuthenticationMode>Unauthenticated</AuthenticationMode>
    <Catalogs>
    <Catalog name="SteelWheels">
    <DataSourceInfo>Provider=mondrian;DataSource=SampleData</DataSourceInfo>
    <Definition>solution:steel-wheels/analysis/steelwheels.mondrian.xml</Definition>
    </Catalog>
    <Catalog name="SampleData">
    <DataSourceInfo>Provider=mondrian;DataSource=SampleData</DataSourceInfo>
    <Definition>solution:steel-wheels/analysis/SampleData.mondrian.xml</Definition>
    </Catalog>
    <Catalog name="ArcStatistics">
    <DataSourceInfo>Provider=mondrian;DataSource=MySql;EnableXmla=False</DataSourceInfo>
    <Definition>solution:steel-wheels/resources/metadata/ArcStatistics.mondrian.xml</Definition>
    </Catalog>
    <Catalog name="ArcStatistics">
    <DataSourceInfo>Provider=mondrian;DataSource=MySql;EnableXmla=False</DataSourceInfo>
    <Definition>solution:Mandinga/resources/metadata/ArcStatistics.mondrian.xml</Definition>
    </Catalog>
    <Catalog name="ArcStatistics2">
    <DataSourceInfo>Provider=mondrian;DataSource=MySql;EnableXmla=False</DataSourceInfo>
    <Definition>solution:Mandinga/resources/metadata/ArcStatistics2.mondrian.xml</Definition>
    </Catalog>
    </Catalogs>
    </DataSource>
    </DataSources>

  5. #5
    Join Date
    Jan 2006
    Posts
    205

    Default

    Do you have your "Mysql" data source defined?

    What does your connections dropdown look like?

  6. #6

    Default

    Quote Originally Posted by mikegreen View Post
    Do you have your "Mysql" data source defined?

    What does your connections dropdown look like?
    Na this doesn't use the PAT connections, that doesn't matter.

    I assume you refreshed the repo etc?
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  7. #7

    Default

    Scratch that, you've got enableXMLA=false. Try true
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  8. #8

    Default

    Thanks!!

    It was the enableXMLA=false, now I can see my cubes in PAT!

    But... why is this set in false when I publish the cube in Spoon?

    May be I have to set something there?

    I have to edit every cube I publish before using it with PAT?

  9. #9

    Default

    For that you'd have to ask a Pentaho dev I'm afraid. I have absolutely no idea why its false(doesn't really make much sense)
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  10. #10

    Default

    Thanks, I could do my first PAT Analysis, but when I save it with the chart view and open it again I don't get the chart, I only see the grid.

    Can I save the pie chart view so when it's open the user sees the pie and not the grid?

  11. #11

    Default

    yeah loading saved queries is currently "interesting" your mileage will vary, we're working on that for the september release.

    Tom
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  12. #12

    Default

    Thanks again Tom, we are waiting here in Buenos Aires for the new cool release ;-)

  13. #13

    Default

    lol people are waiting the world over... we'll get there
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  14. #14

    Default Always a money sign

    I have another question Tom, hope my feedback is worthy ;-)

    When I view the data in a chart mode I always get a $ in the unit.

    I would like to configure this unit, because in this case, this is not $ but a counter of stock.

    Name:  PAT1.jpg
Views: 287
Size:  18.4 KB

    PS: if I don't select "children" when I am building the query and see the chart, PAT shows the total with 50% (of course, because children plus father are 100%), I think this is a king of bug, because may be I would like to see the total of the father in the grid, but not in the pie chart, mix up with the children data.

  15. #15
    Join Date
    Jan 2006
    Posts
    205

    Default

    I would recommend starting each new subject in a new thread, btw... you'll get more reads...

    That said - I logged the issue you speak of earlier today in Jira -
    http://jira.pentaho.com/browse/PAT-349
    If you'd like to add your screenshot or any additional info, please do!

    Regards,

    Mike

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.