Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Issues with Kettle.Properties fie

  1. #1
    Join Date
    Dec 2009
    Posts
    4

    Default Issues with Kettle.Properties fie

    Hi,

    I am using Spoon Version 3.2 on my windows machine.I have created a master job which in turns calls couple of other jobs parallely (around 40 jobs). Everything is parameterized here i.e. the database connections,database ports,mail hosts,server paths etc etc through kettle.properties file.
    When I ran this job it went fine without any issues.But When I ran it couple of times it fails for some runs (I ran it one after another) and log says it is not able to fetch the variable value. below is exact errors what I got

    1. " ERROR 17-08 14:07:14,881 - org.pentaho.di.trans.steps.dbproc.DBProc - An error occurred, processing will be stopped:
    Error occured while trying to connect to the database
    Error connecting to database: (using class oracle.jdbc.driver.OracleDriver)
    Io exception: Invalid number format for port number ".

    2. Problem while sending message: javax.mail.MessagingException: Unknown SMTP host: ${MAIL_HOST};
    nested exception is:
    java.net.UnknownHostException: ${MAIL_HOST}

    3. Couldn't open file ${SVR_PATH}\sharedpath\test.txt

    But when I again re ran the same job,it went fine.
    Any idea how to fix this ?

    Thanks in advance,
    -Amol

  2. #2
    Join Date
    Dec 2009
    Posts
    4

    Default

    Can any one please let me know if there is any way to fix this ?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.