Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Table output - Batch insert mode disabled because of database limitations

  1. #1

    Unhappy Table output - Batch insert mode disabled because of database limitations

    Hi,

    I m using MySQL 5.0 (MyISAM as engine) and I get this message when I use the Table Output step.
    I noticed that the option "Use batch update for inserts" is greyed out.

    My transformation takes over 1 hour now. In the past it was just a matter of minutes.

    I have this problem since I upgraded to PDI 4.x.

    Has anyone else this problem?

    Dirk

  2. #2
    Join Date
    Sep 2007
    Posts
    19

    Default

    I do, using a MS SQLServer 2005 database, I think maybe is a driver's issue.

    EDIT: The drivers aren't the problem. The problem is the error handling feature.
    When error handling is enabled, the batch insert mode can't be enabled.

    More info here: http://forums.pentaho.com/archive/in...p/t-71507.html
    Last edited by crorella; 08-26-2010 at 11:44 AM.

  3. #3

    Default

    Thanks,
    it is a bug since I dont use postGres.

  4. #4

    Default

    I thought I give PDI 4.x another shot, since it been 6 month since my last attempt, but I still get this error:
    "Batch insert mode disabled because of database limitations"
    http://jira.pentaho.com/browse/PDI-4532

    Has anyone else this problem and will it be fixed some day?
    Last edited by dirks; 03-01-2011 at 03:05 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.