Hitachi Vantara Pentaho Community Forums
Results 1 to 19 of 19

Thread: Problems with CDE 1 RC

  1. #1
    Join Date
    Aug 2008
    Posts
    563

    Default Problems with CDE 1 RC

    Hi,
    I moved all the folders to pentaho/system on biserver 3.6 stable. Online, I can create a new dashboard, but I cannot preview it. When I save the file, refresh the repository and open it, it loads (it seems to query the data), but the page stays blank.

    I saw this in the error log:
    17:16:19,016 ERROR [Dashboard] Failed to get cdf includes
    17:16:23,953 ERROR [DashboardDesignerContentGenerator] java.io.FileNotFoundExcep
    tion - C:\pentaho\biserver-ce\biserver-ce\pentaho-solutions\system\pentaho-cdf\R
    ender (The system cannot find the file specified)
    Saving File:/Russia/test1234.cdfde
    deleting File:/Russia/test1234_tmp.cdfde
    Loading File:/Russia/test1234.cdfde
    17:17:50,148 ERROR [GenericServlet] GenericServlet.ERROR_0004 - Resource /pentah
    o-cdf-dd/css/images/ui-bg_flat_50_2d2d2d_40x100.png not found in plugin Dashboar
    d Designer Framework
    17:17:50,211 ERROR [GenericServlet] GenericServlet.ERROR_0004 - Resource /pentah
    o-cdf-dd/css/images/ui-bg_flat_60_2d2d2d_40x100.png not found in plugin Dashboar
    d Designer Framework
    Saving File:/Russia/test1234_tmp.cdfde
    17:17:52,038 ERROR [Dashboard] Failed to get cdf includes
    17:17:52,038 ERROR [DashboardDesignerContentGenerator] java.io.FileNotFoundExcep
    tion - C:\pentaho\biserver-ce\biserver-ce\pentaho-solutions\system\pentaho-cdf\R
    ender (The system cannot find the file specified)
    17:21:00,691 ERROR [Dashboard] Failed to get cdf includes
    17:21:00,706 ERROR [DashboardDesignerContentGenerator] java.io.FileNotFoundExcep
    tion - C:\pentaho\biserver-ce\biserver-ce\pentaho-solutions\system\pentaho-cdf\R
    ender (The system cannot find the file specified)

    How do I solve this?
    Thanks,
    Diddy

  2. #2
    Join Date
    Mar 2010
    Posts
    9

    Default

    Hi,
    I had a similar problem, but got it working by deleting the included three plugin folders under pentaho/system folder and unzipping them again.
    Don't know what was different as I thought I did it the first time as well. Perhaps some old pentaho-cdf stuff was left anyway.
    Hope it helps!

    Best regards,
    Sami

  3. #3
    Join Date
    Aug 2008
    Posts
    563

    Default

    Thanks a lot. I followed your advice and now it is starting to load the dashboard, but I get following error message:
    Error found: [object XMLHttpRequest], cannot read property "DocumentElement" of Null

    Do you have any ideas on how to solve this?
    Thanks,
    Diddy

  4. #4
    Join Date
    Mar 2010
    Posts
    9

    Default

    I assume there is some problem with the component properties. Does for example a predefined template show ok without any components ?
    I think I received somewhat similar error messages when iterating some of the new components until I got the properties set up appropriately.

    BR,
    Sami

  5. #5
    Join Date
    Aug 2008
    Posts
    563

    Default

    Hi Sami,
    Yes, exactly. The template loads, but no components are visible. Can you please point me to the file where I can change the properties? What exactly do I have to change?
    Thanks,
    Diddy
    Last edited by diddy; 10-21-2010 at 05:27 PM.

  6. #6
    Join Date
    Mar 2010
    Posts
    9

    Default

    Hi,
    by properties I meant the attributes you set in Dashboard editor for the component (e.g. HtmlObject, DataSource, Width, Height).
    I guess that as this isn't a stable version, we can expect that some things don't work yet. As well, not all configurations are straightforward; proceeding step-by-step from getting simple stuff working helps.
    Which components and data access methods do you use?

    Br,
    Sami

  7. #7
    Join Date
    Jul 2007
    Posts
    2,498

    Default

    What browser you using? Try firefox or chrome
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

  8. #8
    Join Date
    Aug 2008
    Posts
    563

    Default

    @ Sami:
    I fixed it now: I copied the old CDF folder over from my old server to the new one, and it worked. It looks like I had made some changes to this "old" folder, but I am not too sure any more what it was. When I have time I try to figure it out. Any ideas what it could be?
    Thanks for your help!
    @ Pedro: Thanks as well! (I am working with Chrome mainly, sometimes Firefox)
    Best regards,
    Diddy

  9. #9
    Join Date
    Oct 2010
    Posts
    20

    Default

    Hi.

    I had the same problem and i followed the instructions (delete and copy again pth-solution/system/3 dirs)
    It solved the problem of render the dashboard but i still have one more problem.

    I'll explain all my process.

    I create a dashboard and save it.
    I apply a two colum template and save it ( save after every action i some way to be sure. I don't know if its needed but it shouldn't be bad )
    Then i make a first char following the chart wizard and save it one more time.
    Then i try to make my second chart following the chart wizard ... then it happen to me this:

    Name:  cde_1.jpg
Views: 83
Size:  13.6 KB


    The dimension level or the measure i want to use goes to the preview area without exception.

    Then i can't do anything else with the wizard.

    It happen to me with firefox and chrome....

    I don't attach log because log looks normal.
    Last edited by jortilles; 10-22-2010 at 11:35 AM.

  10. #10
    Join Date
    Jul 2007
    Posts
    2,498

    Default

    Yeah - the wizard in not ported to CDA yet.... sorry
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

  11. #11

    Default

    Same here diddy, I cannot preview the dashboard, I got a blank page.
    How do I solve this?

  12. #12

    Default

    Hi to all,

    I have a problem with the CCC charts, when i try to display a CCC bar chart (or any other CCC chart) i got an error like : "Object type cccBarChart can't be mapped to a valid class", and if i use any other kind of chart, everything works fine.

    Does anyone knows how to solve this?

    Im using Pentaho CE 3.6 and CDE 1.0 RC1, in a server that has a public IP.

    Thanks a lot

    Juan

  13. #13
    Join Date
    Jul 2007
    Posts
    2,498

    Default

    jegordon, when you installed the bundle, did you move away the old CDF directory from solution/system/pentaho-cdf? I think something went wrong with your install
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

  14. #14

    Default

    Hi All,

    Im having the same problem as jegordon, I removed all the files from solutions/system/pentaho-cdf and pentaho-cdf-dd, and replaced with the new ones, but i cant use the CCC charts, is there anything else that I need to do?

    Thanks!!

    NL

  15. #15
    Join Date
    Jul 2007
    Posts
    2,498

    Default

    Do you get any error?
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

  16. #16

    Default

    Thanks for the reply pmalves,

    Yeap I get, Object can't no be mapped to a valid class, did i miss something?

    Thanks

    NL

  17. #17
    Join Date
    Jul 2007
    Posts
    2,498

    Default

    I can't reproduce it... Guess it's time to think about releasing a RC2
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

  18. #18
    Join Date
    Apr 2009
    Posts
    5

    Default

    I am getting a "objct type navigatorMenu can't be mapped to a valid class" error with cde rc1. Any ideas? My initial install worked but I made the following adjustments
    1) applied the fix to crecomponents get FlashChart working with IE7
    2) use apache reverse proxy to access my biserver

    both were necessary, but I can't see why either would cause this error. Any help would be appreciated

  19. #19
    Join Date
    Jul 2007
    Posts
    2,498

    Default

    What exactly is fix 1?

    Also, I've seen some apache proxys that changed the returning jsons, which was kind'a unexpected... I use cde with apache ajp connector and works fine
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.