Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Report Designer 3.7 RC1 - Hive parameter swallows previous chararacter

  1. #1
    Join Date
    Sep 2010

    Default Report Designer 3.7 RC1 - Hive parameter swallows previous chararacter

    I've found that in Report Designer 3.7 RC1, the substitution of a parameter into a Hive query seems to "swallow" the previous character. For example, a query such as this one:

    ... WHERE foobar=${foobar_val} AND ...

    might become:

    ... WHERE foobarNULL AND ...

    rather than:

    ... WHERE foobar=NULL AND ...

    Fortunately, once I figured out that that was what was happening, it was easy to work around: I just had to insert an arbitrary character before the parameter. (For sake of readability, I inserted a space; but I also tried inserting an "x", just for the heck of it, and that worked just as well.)

    Sorry if this issue has already been reported.

  2. #2
    Join Date
    Mar 2008


    Can you please createa Jira for this issue? It is probably not limited to Hive.
    Thank you for bringing this to our attention.

  3. #3
    Join Date
    Sep 2010


    I've created a JIRA ticket:

    I only saw this issue with Hive; it didn't seem to affect PostgreSQL. (Note that the Hive JDBC drivers use the Hive command-line interface under the covers, so it wouldn't shock me if this is a bug inside those drivers, rather than inside Report Designer per se. But they're Pentaho-specific drivers at the moment, and I didn't see a way to file a bug against them, so I filed it under Report Designer as the product that reproducibly experiences the issue.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.