Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: How can I enter a SQL query that involves very big tables in a Birt's dataset

  1. #1

    Default How can I enter a SQL query that involves very big tables in a Birt's dataset

    I´m having a problem because I´m developing a report for my company and using Birt to accomplish it.

    The report contains several datasets and i´m not having any problem (I´ve tested it and works) till I enter a new dataset that involves several big oracle tables (120.000.000 registers).

    The Sql I´m entering in the dataset is correct (because I´ve tested it before in toad an sqldeveloper to ensure it has no mistakes), but when I enter the sql in the new dataset and press "OK" the screen becomes white (like it would be processing the query or something similar) but leaving it even 8 hours I can´t recover the control of Birt (so i must kill it to try again). I´ve tried lot of times with different datasets involving those big tables and none of them have finished.

    Are there any solution to do it. I suppose Birt is checking or prefetching rows when I click the ok button and because the tables are so huge I think it can´t finish or hang itself.

    Can I tell birt not to pre-execute the query but only giving me the name of the columns returned by the SQL in order to use it in the report?

    Can anybody help me?

    Lot of thanks.


  2. #2


    This forum is about running (working) BIRT reports in the Pentaho BI server, you will probably get better support at Birt Exchange.

    Did you make sure Toad and/or sqldeveloper fetch all rows? By default, they only fetch a small number of rows (e.g. 100). Try fetching all rows at once for your query. If this runs well in Toad, it should be ok in BIRT as well.



  3. #3


    First of all sorry for posting there. I thought it was the right place but after that it seems like I posted in the wrong place.

    I´ve tried executing the query in toad and it fetches the rows although it takes lot of time to accomplish it.

    I think when I enter the sql in the dataset Birt begins to fetch or test the SQL and then it hangs and I can´t recover the control.

    Lot of thanks for your answer Bart, What more can I try to do to solve this problem?


  4. #4


    As bamaer notes that you'd be better served at Birt Exchange or even the birt newsgroup at, try adding 1 = 2 to the query --> select * from really_big_table where 1 = 2 and ....more condititions.
    When your finished with your design just change the 1 = 2 into 1 = 1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.