Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Can't connect to MSSQL Server 2008 R2 using Windows Authentication

  1. #1

    Cool Can't connect to MSSQL Server 2008 R2 using Windows Authentication

    Hi,

    I am currently using PDI 3.1, on a Windows Server 2008 R2 (64 bit). I installed the swt.jar patch in the libswt\win32 so Spoon works okay.

    I get the following error while try to connect to my MSSQL database using Spoon. Using Windows authentication.

    Error connecting to database ..: org.pentaho.di.core.exception.KettleDatabaseException:
    Error occurred while trying to connect to the database

    Error connecting to database: (using class net.sourceforge.jtds.dbc.Driver)
    Login failed for user 'test'

    No matter what user I try, they all fail.

    PDI 3.1 is installed on the same server as the database.

    Any help would be greatly appreciated.

    Thanks.

  2. #2
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    Did you configure the driver to use Windows Authentication?
    By default, it uses database authentication.

    domainSpecifies the Windows domain to authenticate in. If present and the user name and password are provided, jTDS uses Windows (NTLM) authentication instead of the usual SQL Server authentication (i.e. the user and password provided are the domain user and password). This allows non-Windows clients to log in to servers which are only configured to accept Windoes authentication.
    If the domain parameter is present but no user name and password are provided, jTDS uses its native Single-Sign-On library and logs in with the logged Windows user's credentials (for this to work one would obviously need to be on Windows, logged into a domain, and also have the SSO library installed -- consult README.SSO in the distribution on how to do this).
    The Windows -> Windoes typo is in the original
    You can add the domain parameter in the Advanced page of the Database configuration window.
    **THIS IS A SIGNATURE - IT GETS POSTED ON (ALMOST) EVERY POST**
    I'm no expert.
    Take my comments at your own risk.

    PDI user since PDI 3.1
    PDI on Windows 7 & Linux

    Please keep in mind (and this may not apply to this thread):
    No forum member is going to do your work for you. We will help you sort out how to do a specific part of the work, as best we can, in the timelines that our work will allow us.
    Signature Updated: 2014-06-30

  3. #3

    Default

    gutlez can you give me some more information - where do I need to go to configure the driver. I did some searching and I couldn't find where to add the domain parameter? Could you be more specific?

    Thanks.

  4. #4
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    In your database window, where you specify the database name, login information, etc. there is an additional screen called advanced.
    Click on it, and it will give you a place to enter parameters and values.
    Add the parameter domain with a value of the name of your domain.

    ie. if you normally log in as EXAMPLE\user you would enter the parameter domain with a value of EXAMPLE
    **THIS IS A SIGNATURE - IT GETS POSTED ON (ALMOST) EVERY POST**
    I'm no expert.
    Take my comments at your own risk.

    PDI user since PDI 3.1
    PDI on Windows 7 & Linux

    Please keep in mind (and this may not apply to this thread):
    No forum member is going to do your work for you. We will help you sort out how to do a specific part of the work, as best we can, in the timelines that our work will allow us.
    Signature Updated: 2014-06-30

  5. #5

    Default

    Works fine. You've made my day.

    Thanks.

  6. #6
    Join Date
    Mar 2007
    Posts
    8

    Default

    gutlez, you've made our weekend (me and my colleague) with that tip!
    Thanks a lot!
    Cheers

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.