Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Job with parameters does not run on Linux - could be a bug!?

  1. #1
    Join Date
    Nov 2010
    Posts
    23

    Unhappy Job with parameters does not run on Linux - could be a bug!?

    Hello-

    I created a job with two parameters on windows, saved the job to a repository. When I run the job from the windows I don't get any issues, I can set the two parameters "input_file" and "output_file" before the job runs and it works fine. But run on a linux using command-line kitchen I run into issues with parameters. I passed the parameters during the -param: argument like the below:

    Code:
    ./kitchen.sh -rep:pilot_repo -user:spunj -pass:password -level:Debug -dir:/TestWork -job:job_test1001 -param:input_file=/spunj/inbound/inf1001/1.dat -param:output_file=/spunj/inbound/inf1001/1.out.dat
    As you can see above, I'm passing two parameters as well as all the necessary parameters to connect to the repository. However PDI thinks the input file to the transformation inside the job is missing and I get the following error:

    INFO 14-02 17:21:11,340 - FF_2_FF - This transformation can be replayed with replay date: 2011/02/14 17:21:11
    ERROR 14-02 17:21:11,363 - Text file input - No file(s) specified! Stop processing.
    ERROR 14-02 17:21:11,368 - Text file input - Error initializing step [Text file input]
    ERROR 14-02 17:21:11,369 - FF_2_FF - Step [Text file input.0] failed to initialize!
    ERROR 14-02 17:21:11,537 - FF_2_FF - Unable to prepare for execution of the transformation
    ERROR 14-02 17:21:11,537 - FF_2_FF - org.pentaho.di.core.exception.KettleException:
    We failed to initialize at least one step. Execution can not begin!
    Here is what I tried:
    I tried the default values and not passing any parameters, same issue.
    I even added a "Write to Log" object in the job itself to see if the parameters are being passed through and they are..!!! but for some reason the transformation downstream does not pick them up.

    I'm attaching the ktr and kjb files for your reference as well as the log file.

    I'm using PDI (version 4.0.1-stable, build 13826 from 2010-08-26 14.18.03 by buildguy)

    Thanks for your help!
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2010
    Posts
    23

    Lightbulb

    I found the problem. I didn't pass the correct values, the files were there but PDI was looking for the file somewhere else because I had it setup to look in a different directory at the transformation level.

    Suggestion: The error thrown out of the input file transfomation can be more descriptive, or less misleading

    ERROR 14-02 17:21:11,363 - Text file input - No file(s) specified! Stop processing.

    The above error is misleading, because I did specify a file, however the the file is not there. An error message saying file not found and with the file name & path attached to the error message would be more accurate and can help allot when diagnosing or debugging

    Since this is open source code, I'm tempted to try and fix this myself, but I really don't know where to start. Can someone tell me? I'm talking about the Text File Input object.

    Thanks

  3. #3
    Join Date
    Nov 2008
    Posts
    143

    Default

    Start by downloading Kettle's source code.
    You should find the svn link pretty easy by googleing kettle svc source.
    Find the Text file input plugin code and start your coding

  4. #4
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    As an initial stop-gap, you could code it into your job...

    Check all your parameters for sanity before proceeding, and if one of them is not sane, then error out and log why.
    **THIS IS A SIGNATURE - IT GETS POSTED ON (ALMOST) EVERY POST**
    I'm no expert.
    Take my comments at your own risk.

    PDI user since PDI 3.1
    PDI on Windows 7 & Linux

    Please keep in mind (and this may not apply to this thread):
    No forum member is going to do your work for you. We will help you sort out how to do a specific part of the work, as best we can, in the timelines that our work will allow us.
    Signature Updated: 2014-06-30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.