Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Table Input step not recognising Alias field names in SQL query

  1. #1
    Join Date
    Jan 2011
    Posts
    3

    Default Table Input step not recognising Alias field names in SQL query

    Hi,

    I have a table input step which feeds its result set into a table output set.

    I have used a field alias for multiple instances of id fields in the SQL query e.g:

    select a.id as user, b.id as driver, c.id as vehicle
    from user a, driver b, vehicle c;

    But the query is replacing these aliases with:

    id, id_1, id_2.

    So this now messes up the table output field matching.

    Any ideas of how to resolve this? It was working fine previously.

    Regards,
    Colin Mooney

  2. #2
    Join Date
    Jan 2011
    Posts
    3

    Default

    I resolved this. It was the MySQL driver which was causing the issue. Once I reverted back to the previous version, all was ok.

    The version causing the problem was:
    mysql-connector-java-5.1.15

  3. #3
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    Sorry about that one. It slipped in because of a packaging error. I believe we reverted to the 3.x series for now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.