Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Data Type Error

  1. #1
    Join Date
    Feb 2010
    Posts
    4

    Default Data Type Error

    PDI Log.txtBID1101T - Load DIM_CONTRACTS-dlb.ktr

    I've recently made a modification to a PDI script (version 4.0.1-stable, build 13826 from 2010-08-26 14.18.03) that has resulted in the sporadic occurrence of the following error:

    Select values 3.0 - ERROR : Unexpected error :
    Select values 3.0 - ERROR : org.pentaho.di.core.exception.KettleValueException:
    Select values 3.0 - ERROR : COND_EFFECT_TO_DATE Date : There was a data type error: the data type of java.lang.String object [changed] does not correspond to value meta [Date]
    Select values 3.0 - ERROR : org.pentaho.di.core.row.ValueMeta.getString(ValueMeta.java:1350)
    Select values 3.0 - ERROR : org.pentaho.di.core.row.RowMeta.getString(RowMeta.java:184)...

    There are some strange things about how it happens. On my input step, I've changed my selects to limit the input to only a few records for debugging purposes. If I run the entire set of these records through, I consistently get the error on 3 different steps at the end of the transformation. However, if I select only a few records of the subset at a time, through multiple runs, all of the records flow through successfully w/o any errors.

    Additionally, under various combinations of record selections, the error shows up at 1, 2, or 3 of the steps. As you can see, I've added text file outputs for debugging purposes before and after the failure points. I have gotten the error on these steps as well.

    Even though every place I use the offending column, it's defined as a date, I added a step to alter the meta-date to a date data type to see if that made any difference, but continued to get the error.

    Apologies for the lengthy description. I tried to be as brief as possible. If anyone has seen this happen before or has any suggestions on how to correct it, I would be greatly appreciative.

  2. #2
    Join Date
    Feb 2010
    Posts
    4

    Default

    I figured out the issue. I had multiple streams converging into one step. One of the streams had its output in a different order than the others. Once I reset them to the same order, the error went away.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.