Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Error on execute a transformation with pan.sh in Red Hat Enterprise Linux 5

  1. #1
    Join Date
    Feb 2011
    Posts
    2

    Unhappy Error on execute a transformation with pan.sh in Red Hat Enterprise Linux 5

    PLease i need help, I try to execute a transformation with pan.sh on Red Hat Enterprise Linux 5 this is the comand pan.sh -file="/data/transformation/test.ktr" -level=Minimal

    but its not work an show me the following errors:

    Exception in thread "main" java.lang.NoClassDefFoundError: org.pentaho.di.core.logging.LoggingRegistry
    at java.lang.Class.initializeClass(libgcj.so.7rh)
    at org.pentaho.di.core.logging.LogChannel.<init>(LogChannel.java:31)
    at org.pentaho.di.i18n.GlobalMessages.<clinit>(GlobalMessages.java:45)
    at java.lang.Class.initializeClass(libgcj.so.7rh)
    at java.lang.Class.initializeClass(libgcj.so.7rh)
    at java.lang.Class.newInstance(libgcj.so.7rh)
    at org.pentaho.di.laf.LAFDelegate.loadHandler(LAFDelegate.java:73)
    at org.pentaho.di.laf.LAFDelegate.init(LAFDelegate.java:48)
    at org.pentaho.di.laf.LAFDelegate.<init>(LAFDelegate.java:40)
    at org.pentaho.di.laf.LAFFactory.getDelegate(LAFFactory.java:50)
    at org.pentaho.di.laf.LAFFactory.getHandler(LAFFactory.java:64)
    at org.pentaho.di.i18n.BaseMessages.init(BaseMessages.java:42)
    at org.pentaho.di.i18n.BaseMessages.<init>(BaseMessages.java:37)
    at org.pentaho.di.i18n.BaseMessages.getInstance(BaseMessages.java:47)
    at org.pentaho.di.i18n.BaseMessages.<clinit>(BaseMessages.java:33)
    at java.lang.Class.initializeClass(libgcj.so.7rh)
    at org.pentaho.di.core.logging.LogLevel.<clinit>(LogLevel.java:29)
    at java.lang.Class.initializeClass(libgcj.so.7rh)
    at org.pentaho.di.core.logging.DefaultLogLevel.<init>(DefaultLogLevel.java:26)
    at org.pentaho.di.core.logging.DefaultLogLevel.getInstance(DefaultLogLevel.java:31)
    at org.pentaho.di.core.logging.DefaultLogLevel.getLogLevel(DefaultLogLevel.java:40)
    at org.pentaho.di.core.logging.LogChannel.<init>(LogChannel.java:30)
    at org.pentaho.di.core.logging.LogChannel.<clinit>(LogChannel.java:18)
    at java.lang.Class.initializeClass(libgcj.so.7rh)
    at org.pentaho.di.core.KettleEnvironment.createDefaultKettleProperties(KettleEnvironment.java:109)
    at org.pentaho.di.core.KettleEnvironment.createKettleHome(KettleEnvironment.java:100)
    at org.pentaho.di.core.KettleEnvironment.init(KettleEnvironment.java:50)
    at org.pentaho.di.core.KettleEnvironment.init(KettleEnvironment.java:42)
    at org.pentaho.di.pan.Pan.main(Pan.java:55)
    Caused by: java.lang.ClassNotFoundException: java.util.concurrent.ConcurrentHashMap not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:/data01/install/pdi/data_integration/,file:/data01/install/pdi/data_integration/lib/kettle-core.jar,file:/data01/install/pdi/data_integration/lib/kettle-db.jar,file:/data01/install/pdi/data_integration/lib/kettle-engine.jar,file:/data01/install/pdi/data_integration/libext/log4j-1.2.14.jar,file:/data01/install/pdi/data_integration/libext/slf4j-api-1.5.8.jar,file:/data01/install/pdi/data_integration/libext/saxon8.jar,file:/data01/install/pdi/data_integration/libext/salesforce/jaxrpc.jar,file:/data01/install/pdi/data_integration/libext/salesforce/axis.jar,file:/data01/install/pdi/data_integration/libext/salesforce/salesforce20.0.jar,file:/data01/install/pdi/data_integration/libext/salesforce/commons-discovery-0.2.jar,file:/data01/install/pdi/data_integration/libext/salesforce/saaj.jar,file:/data01/install/pdi/data_integration/libext/web/jetty-util-6.1.21.jar,file:/data01/install/pdi/data_integration/libext/web/activation.jar,file:/data01/install/pdi/data_integration/libext/web/servlet-api-2.5-6.1.9.jar,file:/data01/install/pdi/data_integration/libext/web/jetty-6.1.21.jar,file:/data01/install/pdi/data_integration/libext/web/simple-jndi-0.11.1.jar,file:/data01/install/pdi/data_integration/libext/web/jetty-plus-6.1.21.jar,file:/data01/install/pdi/data_integration/libext/jsch-0.1.42.jar,file:/data01/install/pdi/data_integration/libext/ftp4che-0.7.1.jar,file:/data01/install/pdi/data_integration/libext/poi-ooxml-schemas-3.6-20091214.jar,file:/data01/install/pdi/data_integration/libext/spring/spring-beans-2.5.6.jar,file:/data01/install/pdi/data_integration/libext/spring/spring-core-2.5.6.jar,file:/data01/install/pdi/data_integration/libext/spring/spring-context-2.5.6.jar,file:/data01/install/pdi/data_integration/libext/spring/spring-context-support-2.5.6.jar,file:/data01/install/pdi/data_integration/libext/syslog4j-0.9.34.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-digester-1.8.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-io-1.4.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-codec-1.3.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-logging-1.1.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-validator-1.3.1.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-pool-1.3.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-collections-3.1.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-httpclient-3.0.1.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-fileupload-1.0.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-beanutils-1.7.0.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-lang-2.4.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-dbcp-1.2.1.jar,file:/data01/install/pdi/data_integration/libext/commons/commons-net-1.4.1.jar,file:/data01/install/pdi/data_integration/libext/feeds/rome-1.0.jar,file:/data01/install/pdi/data_integration/libext/feeds/feed4j.jar,file:/data01/install/pdi/data_integration/libext/feeds/nekohtml.jar,file:/data01/install/pdi/data_integration/libext/feeds/xml-apis.jar,file:/data01/install/pdi/data_integration/libext/feeds/jdom.jar,file:/data01/install/pdi/data_integration/libext/feeds/georss-rome-0.9.8.jar,file:/data01/install/pdi/data_integration/libext/javassist.jar,file:/data01/install/pdi/data_integration/libext/scannotation-1.0.2.jar,file:/data01/install/pdi/data_integration/libext/jackcess-1.2.1.jar,file:/data01/install/pdi/data_integration/libext/trilead-ssh2-build213.jar,file:/data01/install/pdi/data_integration/libext/ini4j-0.5.1.jar,file:/data01/install/pdi/data_integration/libext/poi-ooxml-3.6-20091214.jar,file:/data01/install/pdi/data_integration/libext/ascsapjco3wrp.jar,file:/data01/install/pdi/data_integration/libext/json_simple-1.1.jar,file:/data01/install/pdi/data_integration/libext/palo-core.jar,file:/data01/install/pdi/data_integration/libext/jug-lgpl-2.0.0.jar,file:/data01/install/pdi/data_integration/libext/xercesImpl-2.9.1.jar,file:/data01/install/pdi/data_integration/libext/pentaho/kettle-vfs-20100924.jar,file:/data01/install/pdi/data_integration/libext/pentaho/libbase-1.2.1.jar,file:/data01/install/pdi/data_integration/libext/pentaho/pentaho-xul-swt-3.2.1.jar,file:/data01/install/pdi/data_integration/libext/pentaho/sqleonardo-swt-wrapper.jar,file:/data01/install/pdi/data_integration/libext/pentaho/jets3t-0.7.4.jar,file:/data01/install/pdi/data_integration/libext/pentaho/hadoop-core-0.20.2.jar,file:/data01/install/pdi/data_integration/libext/pentaho/pentaho-s3-vfs-1.0.1.jar,file:/data01/install/pdi/data_integration/libext/pentaho/libformula-1.2.1.jar,file:/data01/install/pdi/data_integration/libext/pentaho/olap4j-0.9.8.340.jar,file:/data01/install/pdi/data_integration/libext/pentaho/pentaho-xul-core-3.2.1.jar,file:/data01/install/pdi/data_integration/libext/pentaho/sqleonardo.jar,file:/data01/install/pdi/data_integration/libext/pentaho/pentaho-hdfs-vfs-1.0.0.jar,file:/data01/install/pdi/data_integration/libext/pentaho/pentaho-database-4.0.5.jar,file:/data01/install/pdi/data_integration/libext/pentaho/pentaho-formula-editor-0.0.1.jar,file:/data01/install/pdi/data_integration/libext/pentaho/pentaho-vfs-browser-2.0.2.jar,file:/data01/install/pdi/data_integration/libext/snakeyaml-1.7.jar,file:/data01/install/pdi/data_integration/libext/JDBC/vertica_3.5_jdk_5.jar,file:/data01/install/pdi/data_integration/libext/JDBC/hsqldb.jar,file:/data01/install/pdi/data_integration/libext/JDBC/sqlitejdbc-v037-nested.jar,file:/data01/install/pdi/data_integration/libext/JDBC/kingbasejdbc.jar,file:/data01/install/pdi/data_integration/libext/JDBC/iijdbc.jar,file:/data01/install/pdi/data_integration/libext/JDBC/orai18n.jar,file:/data01/install/pdi/data_integration/libext/JDBC/derby.jar,file:/data01/install/pdi/data_integration/libext/JDBC/jtds-1.2.5.jar,file:/data01/install/pdi/data_integration/libext/JDBC/unijdbc.jar,file:/data01/install/pdi/data_integration/libext/JDBC/monetdb-1.7-jdbc.jar,file:/data01/install/pdi/data_integration/libext/JDBC/ifxjdbc.jar,file:/data01/install/pdi/data_integration/libext/JDBC/postgresql-8.3-603.jdbc3.jar,file:/data01/install/pdi/data_integration/libext/JDBC/hive-jdbc-0.5.0-pentaho-1.0.0.jar,file:/data01/install/pdi/data_integration/libext/JDBC/xdbjdbc.jar,file:/data01/install/pdi/data_integration/libext/JDBC/infobright-core-3.3.jar,file:/data01/install/pdi/data_integration/libext/JDBC/LucidDbClient-minimal.jar,file:/data01/install/pdi/data_integration/libext/JDBC/jaybird-full-2.1.0.jar,file:/data01/install/pdi/data_integration/libext/JDBC/mysql-connector-java-3.1.14-bin.jar,file:/data01/install/pdi/data_integration/libext/JDBC/db2jcc.jar,file:/data01/install/pdi/data_integration/libext/JDBC/h2.jar,file:/data01/install/pdi/data_integration/libext/JDBC/sapdbc.jar,file:/data01/install/pdi/data_integration/libext/JDBC/jt400.jar,file:/data01/install/pdi/data_integration/libext/JDBC/rdbthin.jar,file:/data01/install/pdi/data_integration/libext/JDBC/ojdbc14.jar,file:/data01/install/pdi/data_integration/libext/JDBC/derbyclient.jar,file:/data01/install/pdi/data_integration/libext/JDBC/interclient.jar,file:/data01/install/pdi/data_integration/libext/JDBC/db2jcc_license_cu.jar,file:/data01/install/pdi/data_integration/libext/secondstring.jar,file:/data01/install/pdi/data_integration/libext/hive/hive-metastore-0.5.0-pentaho-1.0.0.jar,file:/data01/install/pdi/data_integration/libext/hive/libfb303.jar,file:/data01/install/pdi/data_integration/libext/hive/hadoop-core-0.20.0.jar,file:/data01/install/pdi/data_integration/libext/hive/libthrift.jar,file:/data01/install/pdi/data_integration/libext/hive/hive-service-0.5.0-pentaho-1.0.0.jar,file:/data01/install/pdi/data_integration/libext/hive/hive-exec-0.5.0-pentaho-1.0.0.jar,file:/data01/install/pdi/data_integration/libext/jaxen-1.1.1.jar,file:/data01/install/pdi/data_integration/libext/webservices/wstx-asl-3.2.9.jar,file:/data01/install/pdi/data_integration/libext/webservices/qname.jar,file:/data01/install/pdi/data_integration/libext/webservices/jsr173_api.jar,file:/data01/install/pdi/data_integration/libext/webservices/wsdl4j.jar,file:/data01/install/pdi/data_integration/libext/webservices/xalan-2.4.1.jar,file:/data01/install/pdi/data_integration/libext/javadbf.jar,file:/data01/install/pdi/data_integration/libext/livetribe-jsr223-2.0.6.jar,file:/data01/install/pdi/data_integration/libext/js.jar,file:/data01/install/pdi/data_integration/libext/janino.jar,file:/data01/install/pdi/data_integration/libext/jcifs-1.3.3.jar,file:/data01/install/pdi/data_integration/libext/odfdom.jar,file:/data01/install/pdi/data_integration/libext/SNMP4J.jar,file:/data01/install/pdi/data_integration/libext/junit-4.7.jar,file:/data01/install/pdi/data_integration/libext/dom4j-1.6.1.jar,file:/data01/install/pdi/data_integration/libext/mail.jar,file:/data01/install/pdi/data_integration/libext/edtftpj2.1.jar,file:/data01/install/pdi/data_integration/libext/jxl.jar,file:/data01/install/pdi/data_integration/libext/ognl-2.6.9.jar,file:/data01/install/pdi/data_integration/libext/slf4j-jcl-1.5.8.jar,file:/data01/install/pdi/data_integration/libext/mondrian/eigenbase-xom-1.3.0.13768.jar,file:/data01/install/pdi/data_integration/libext/mondrian/mondrian-3.2.1.13885.jar,file:/data01/install/pdi/data_integration/libext/mondrian/javacup-10k.jar,file:/data01/install/pdi/data_integration/libext/mondrian/saxon8-xom.jar,file:/data01/install/pdi/data_integration/libext/mondrian/commons-math-1.1.jar,file:/data01/install/pdi/data_integration/libext/mondrian/eigenbase-resgen-1.3.0.13768.jar,file:/data01/install/pdi/data_integration/libext/mondrian/eigenbase-properties-1.1.0.10924.jar,file:/data01/install/pdi/data_integration/libext/jfree/jfreechart-1.0.1.jar,file:/data01/install/pdi/data_integration/libext/jfree/jcommon-1.0.14.jar,file:/data01/install/pdi/data_integration/libext/jakarta-oro-2.0.8.jar,file:/data01/install/pdi/data_integration/libext/poi-3.6-20091214.jar,file:/data01/install/pdi/data_integration/libext/rules/drools-api-5.0.1.jar,file:/data01/install/pdi/data_integration/libext/rules/mvel2-2.0.10.jar,file:/data01/install/pdi/data_integration/libext/rules/antlr-runtime-3.1.1.jar,file:/data01/install/pdi/data_integration/libext/rules/drools-compiler-5.0.1.jar,file:/data01/install/pdi/data_integration/libext/rules/drools-core-5.0.1.jar,file:/data01/install/pdi/data_integration/libext/rules/core-3.4.2.v_883_R34x.jar,file:/data01/install/pdi/data_integration/libext/ldapjdk.jar,file:/data01/install/pdi/data_integration/libext/ojdbc14.jar,file:/data01/install/pdi/data_integration/libext/xbean.jar,file:/data01/install/pdi/data_integration/libext/jsonpath.jar,file:/data01/install/pdi/data_integration/libext/JDBC/asjava.zip], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
    at java.net.URLClassLoader.findClass(libgcj.so.7rh)
    at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.7rh)
    at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
    at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
    at java.lang.Class.forName(libgcj.so.7rh)
    at java.lang.Class.initializeClass(libgcj.so.7rh)
    ...28 more

    Please some body help me...an i sorry for my english

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    Install and use Sun Java6 JRE or OpenJDK if you have to, but not the GNU Java that comes on RHEL.

  3. #3
    Join Date
    Mar 2010
    Posts
    159

    Default

    It is trying to use the gcj java that is installed on RHEL 5 by default, which won't work with PDI.

    You need to download and install a recent Sun JRE or JDK and install that on your server. Make sure you get JAVA_HOME and PENTAHO_JAVA_HOME set to the directory of that install.

    Regards,
    Jeremy

  4. #4
    Join Date
    Feb 2011
    Posts
    2

    Default

    Quote Originally Posted by jbeal View Post
    It is trying to use the gcj java that is installed on RHEL 5 by default, which won't work with PDI.

    You need to download and install a recent Sun JRE or JDK and install that on your server. Make sure you get JAVA_HOME and PENTAHO_JAVA_HOME set to the directory of that install.

    Regards,
    Jeremy
    Ok I installed de jdk-6u24 and jre-6u24 in my rhel5 server where i can change the path of JAVA_HOME and PENTAHO_JAVA_HOME in pan.sh or set-pentaho-env.sh, sorry Iam not expert

  5. #5
    Join Date
    Mar 2010
    Posts
    159

    Default

    I would set them in the environment of the user that is invoking pan.sh - but if you want to hard-code it in the script, I'm not really sure which runs first. You should be able to try in one or the other near the beginning and get it to work.

    Regards,
    Jeremy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.