Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Schema must be set

  1. #1
    Join Date
    Mar 2011
    Posts
    140

    Cool Schema must be set

    Hello there,

    I'm using the schema workbench and I'm getting an error when adding a table saying: "Schema must be set". However in the dropdown list there is nothing to be selected. What am I doing wrong here ?

    I'm using MySQL.

  2. #2
    Join Date
    Jun 2011
    Posts
    6

    Default

    Bump...

  3. #3
    Join Date
    Mar 2011
    Posts
    140

    Default

    So, I tend to ignore this issue, since all goes well.

    I'm guessing it is using the default schema, however it's still complaining about it. Hence the confusion.

  4. #4
    Join Date
    Apr 2012
    Posts
    6

    Default

    Hi

    I am also facing the same problem.. can i knw the solution to it..

  5. #5
    Join Date
    Mar 2007
    Posts
    142

    Default

    In the menus at the top of the window, there is an option called "Require Schema". If this is activated and you don't specify the schema name along with the names of tables, this error shows up to remind you that you haven't specified the schema. Either disable the "require schema" option or add the schema name to your tables.
    Luc Boudreau
    aka. Luc le Magnifique
    aka. Monsieur Oui Oui

    Lead Engineer, Pentaho Corporation
    Web: http://devdonkey.blogspot.com
    Twitter: luclemagnifique
    IRC: Monsieur_Oui_Oui@freenode

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.