Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: How to disable Haddop Plugin

  1. #1

    Default How to disable Haddop Plugin

    After the updated of our PDI EE to 4.1.2 we have an ERROR entry in our log file about a missing Licence Files for the Haddop Plugin.

    ERROR 01-04 17:44:03,131 - Error loading plugin: HIVE/Hadoop Hive{class org.pentaho.di.core.plugins.DatabasePluginType}
    org.pentaho.di.core.exception.KettlePluginException:
    Unexpected error loading class:
    Missing, invalid, or expired product license: Pentaho Hadoop Enterprise Edition

    at org.pentaho.di.core.plugins.PluginRegistry.loadClass(PluginRegistry.java:381)
    at org.pentaho.di.core.plugins.PluginRegistry.loadClass(PluginRegistry.java:240)
    at org.pentaho.di.core.database.DatabaseMeta.getDatabaseInterfacesMap(DatabaseMeta.java:1302)
    at org.pentaho.di.core.database.DatabaseMeta.findDatabaseInterface(DatabaseMeta.java:488)
    at org.pentaho.di.core.database.DatabaseMeta.getDatabaseInterface(DatabaseMeta.java:461)
    at org.pentaho.di.core.database.DatabaseMeta.setValues(DatabaseMeta.java:536)
    at org.pentaho.di.core.database.DatabaseMeta.setDefault(DatabaseMeta.java:412)
    at org.pentaho.di.core.database.DatabaseMeta.<init>(DatabaseMeta.java:402)
    at org.pentaho.di.core.database.DatabaseMeta.<init>(DatabaseMeta.java:864)
    at org.pentaho.di.shared.SharedObjects.<init>(SharedObjects.java:120)
    at org.pentaho.di.job.JobMeta.readSharedObjects(JobMeta.java:1004)
    at org.pentaho.di.job.JobMeta.loadXML(JobMeta.java:820)
    at org.pentaho.di.job.JobMeta.loadXML(JobMeta.java:750)
    at org.pentaho.di.job.JobMeta.<init>(JobMeta.java:692)
    at org.pentaho.di.job.JobMeta.<init>(JobMeta.java:664)
    at org.pentaho.di.kitchen.Kitchen.main(Kitchen.java:261)
    Caused by: java.lang.Throwable: Missing, invalid, or expired product license: Pentaho Hadoop Enterprise Edition


    * the ETL runs fine (even after the ERROR entry)
    * we don't need the Hadoop plugin

    My question: how do I disable the (Hadoop) PDI-Plugins in a controlled way?

  2. #2
    Join Date
    Dec 2009
    Posts
    332

    Default

    I have the same problem. We probably both should get new license keys, but in the meantime, the fix is pretty easy.

    Simply move the folders that have "hadoop" in their name from your plugins directories to somewhere else (or delete them). Then start up pentaho like usual.

  3. #3

    Default

    Thx for the info.

    I will try the approach.

  4. #4

    Default Removing the directories worked

    Same problem here, and the solution to delete the Hadoop-plugin directories under plugins worked for version 4.1.2.1 (EE):
    …/data-integration/plugins$ rm -r pdi-hadoop-plugin/

    …/data-integration/plugins$ rm -r pdi-hadoop-plugin-ee/
    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.