Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Fields that were not found ?

  1. #1
    Join Date
    Jul 2010
    Posts
    7

    Default Fields that were not found ?

    Hi,
    I've used an "Add a checksum" step. However, when I validate that step it errors with "Fields that were not found in input stream : [] [] [] [] null [] []"

    All the fields I selected were fetched from a table input step in Oracle using NVL(field, '') to prevent null values.

    Any ideas what might be wrong?

    Thanks in advance.

  2. #2
    Join Date
    Jul 2010
    Posts
    7

    Default Oracle issue?

    After a bit of digging around it seems that the problem arises when Oracle is the source for the table input step which feeds the Add Checksum.

  3. #3
    Join Date
    Jul 2010
    Posts
    7

    Default

    The 'Add a checksum' step is not easy to edit. You cannot delete fields already entered making it impossible to manipulate the list.
    I found a workaround. Create a temporary 'Select Values' step to edit the field list required and use that to populate the 'Add a Checksum' field list.
    Remove the Select Values step and reconnect the original stream.

    Has any one else had problems using 'Add a Checksum'?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.