Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Pentaho reporting integration

  1. #1
    Join Date
    May 2011

    Default Pentaho reporting integration

    Hi, I have a tapestry 5 project building with maven.
    When I include the pentaho's artifactory in the pom:


    I get everything ok in netbeans, but when compiling, I get an exception:
    Caused by: java.lang.SecurityException: sealing violation: can't seal package javax.naming: already loaded

    Any ideas ?
    Regards !

  2. #2
    Join Date
    Mar 2003


    First, you are using a really really really ancient version of the reporting engine. The most current version is 3.8.0.

    The exception you get is not directly caused by the reporting engine, but probably by one of the dependencies. Check whether you see a JNDI related jar in the list of files maven pulls down. After all, you are using a ancient version which was meant to run against JDK 1.2, where JNDI was not yet part of the core JDK.
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  3. #3
    Join Date
    May 2011

    Default Still with issues

    Yes, but that is in another artifactory tree.
    I solved it using the latest, but had to include manually all other dependencies.
    I have it now. I see the reporting engine starting up but I am getting an exception opening the report definition.
    I have tried with other reports (sample ones that come with the code) and those ones I can compile and use in the samples of the sdk
    This is the error I am getting: (Thanks a lot)

    [ERROR]parser.LoggingErrorHandler Fatal Parser-Error:Content is not allowed in prolog.
    24/05/2011 16:19:02 pentaho.PentahoTest getReportDefinition
    GRAVE: null
    org.pentaho.reporting.libraries.resourceloader.ResourceCreationException: Unable to parse the document: ResourceKey{schema=org.pentaho.reporting.libraries.docbundle.bundleloader.ZipResourceBundleLoader, identifier=mimetype, factoryParameters={org.pentaho.reporting.libraries.resourceloader.FactoryParameterKey{name=repository}=org.pentaho.reporting.libraries.repository.zipreader.ZipReadRepository@5203b97, org.pentaho.reporting.libraries.resourceloader.FactoryParameterKey{name=repository-loader}=org.pentaho.reporting.libraries.docbundle.bundleloader.ZipResourceBundleLoader@7283922}, parent=ResourceKey{schema=org.pentaho.reporting.libraries.resourceloader.loader.URLResourceLoader, identifier=file:/home/ale/ale/laburo/NetBeansProjects/servir/reportes/reporte2.prpt, factoryParameters={}, parent=null}}
    at org.pentaho.reporting.libraries.xmlns.parser.AbstractXmlResourceFactory.create(
    at org.pentaho.reporting.libraries.resourceloader.DefaultResourceManagerBackend.create(
    at org.pentaho.reporting.libraries.resourceloader.ResourceManager.create(
    at org.pentaho.reporting.libraries.resourceloader.ResourceManager.create(
    at org.pentaho.reporting.libraries.resourceloader.ResourceManager.createDirectly(
    at pentaho.PentahoTest.getReportDefinition(
    at pentaho.PentahoTest$2.produceMydata(
    at pentaho.PentahoTest$2.produce(
    at pentaho.PentahoTest$2.produce(
    at java.util.concurrent.FutureTask$Sync.innerRun(
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
    at java.util.concurrent.ThreadPoolExecutor$
    Caused by: org.xml.sax.SAXParseException: Content is not allowed in prolog.
    at org.pentaho.reporting.libraries.xmlns.parser.AbstractXmlResourceFactory.create(


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.