Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Published Metadata visibility issue

  1. #1
    Join Date
    Oct 2006
    Posts
    24

    Default Published Metadata visibility issue

    Hello.

    I created a metadata model and published it to server. I can login as admin user and work with it. If I login in as a user, I am not able to see it when I go to create a new report.

    How can I grant the role or user access to the Model so they can use PUC to create basic reports?

    Logged in as Admin :
    1) Used Admin console to create a demo role and demo user.
    2) Assigned demo user to demo role

    3) I created a folder in Browser panel
    4) Used property editor to add demo role with no rights to all items except steel wheels demo
    5) granted demo role Create, update, execute and schedule rights to demo folder.
    6) published DemoModel metadata to demo folder
    7) login as admin to create a test query and it works fine. I try various to make sure my joins are working correctly.
    8) login as demo user and am not able to see demo model to create a report
    9) try opening sample saved when logged in as admin and get error.

    9) Log as admin user and give demo user full rights to demo folder and
    10) log back in as demo user get error :

    The Pentaho BI Platform reported an error while running an action sequence
    Possible Causes:

    RuntimeContext.ERROR_0017 - Action failed to execute

    Action Sequence:test.waqr.xaction
    Execution Stack:

    EXECUTING ACTION: rule (MQLRelationalDataComponent)

    Loop Index (1-based):0
    Error Time:Sunday, July 17, 2011 11:13:04 AM PDT
    Error Type:ActionExecutionException
    Session ID:aademo
    Instance Id:6a78c389-b0a0-11e0-9079-39cf1afa41df
    Action Class:MQLRelationalDataComponent
    Action Description:rule

    Not sure what to do. How do I give the user access to the data model. Do I need to enable security? What will that do to the existing demo data.


    -Lou

  2. #2
    Join Date
    Oct 2006
    Posts
    24

    Default

    I elevated rights for demo user and published metadata to server under that use and still cannot see the data model unless I login as Admin user. I will start using Google this hopefully has occurred before.

    Cheers!

    - Lou

  3. #3
    Join Date
    Oct 2006
    Posts
    24

    Default

    Issue resolved by pulling the security information into the Metadata editor after restarting servers.

  4. #4
    Join Date
    Jul 2011
    Posts
    4

    Default

    How do I give the user access permission to the data model. Do I need to enable security? What will do .

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.