Hitachi Vantara Pentaho Community Forums
Results 1 to 14 of 14

Thread: SPOON.bat displays a "javaw" missing error.

  1. #1

    Default SPOON.bat displays a "javaw" missing error.

    After unzipping the file pdi-ee-4.2-SNAPSHOT.tar.zip(4.2 rc1), under the data-integration folder when i try to run spool.bat(batch file) i get the error "Windows cannot find 'javaw'.Make sure you typed the name correctly, and then try again.". I have written the error that appears cmd prompt also

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.
    C:\Users\LUser>d:
    D:\>c:
    C:\Users\LUser>C:\Pentaho Installations\pdi-ee\data-integration
    'C:\Pentaho' is not recognized as an internal or external command,
    operable program or batch file.
    C:\Users\LUser>cd ../..
    C:\>cd Pentaho Installations\pdi-ee\data-integration
    C:\Pentaho Installations\pdi-ee\data-integration>spoon.bat
    WARNING: Using java from path
    DEBUG: _PENTAHO_JAVA_HOME=
    DEBUG: _PENTAHO_JAVA=javaw
    DEBUG: PENTAHO_INSTALLED_LICENSE_PATH=
    The system cannot find the path specified.
    The system cannot find the path specified.
    C:\Pentaho Installations\pdi-ee\data-integration>start "Spoon" "javaw" "-Xmx512m
    " "-XX:MaxPermSize=256m" "-Djava.library.path=libswt\win32" "-DKETTLE_HOME=" "-D
    KETTLE_REPOSITORY=" "-DKETTLE_USER=" "-DKETTLE_PASSWORD=" "-DKETTLE_PLUGIN_PACKA
    GES=" "-DKETTLE_LOG_SIZE_LIMIT=" -jar launcher\launcher.jar -lib ..\libswt\win32
    The system cannot find the file javaw.
    C:\Pentaho Installations\pdi-ee\data-integration>


    The following steps have been undertaken to verify Java is present on the system:
    1) Installation of java with latest version 6 and updated till 10/8/2011.
    2)Present under the path C:\Program Files (x86)\Java\jre6\bin\javaw
    The error has been attached for your reference.
    Please let us know accordingly if you have any solution to this. Thank You.

  2. #2
    Join Date
    Dec 2009
    Posts
    609

    Default

    Hi,

    you downloaded the Enterprise-Edition? Can PDI not be started from within the Windows Start-Menu?
    Otherwise: Try setting your JAVA_HOME environment variable to the installation directory of your JRE:
    set JAVA_HOME=C:\Program Files (x86)\Java\jre6
    then rerun spoon.bat

    Cheers,

    Tom

    P.S. Another idea: Do not install in a directory-name which contains blanks

  3. #3

    Default

    Hi Tom,
    Thanks for your update. I tried as you suggested and even re-installed Java in a path/directory which does not have blanks. Now what happens is once i run the spoon.bat from the cmd prompt the application does not start at all. The paths are addresses are all taken in,but nothing happens. This is what is displayed in the cmd prompt.

    C:\Users\LUser>d:

    D:\Office_YouView\Pentaho Installation\pdi-ee\data-integration>spoon.bat
    DEBUG: Using JAVA_HOME
    DEBUG: _PENTAHO_JAVA_HOME=C:\Program Files (x86)\Java\jdk1.6.0_27
    DEBUG: _PENTAHO_JAVA=C:\Program Files (x86)\Java\jdk1.6.0_27\bin\javaw
    DEBUG: PENTAHO_INSTALLED_LICENSE_PATH=

    D:\Office_YouView\Pentaho Installation\pdi-ee\data-integration>start "Spoon" "C:
    \Program Files (x86)\Java\jdk1.6.0_27\bin\javaw" "-Xmx512m" "-XX:MaxPermSize=256
    m" "-Djava.library.path=libswt\win32" "-DKETTLE_HOME=" "-DKETTLE_REPOSITORY=" "-
    DKETTLE_USER=" "-DKETTLE_PASSWORD=" "-DKETTLE_PLUGIN_PACKAGES=" "-DKETTLE_LOG_SI
    ZE_LIMIT=" -jar launcher\launcher.jar -lib ..\libswt\win32


    the SPOON does not start. Any suggestions??

  4. #4
    Join Date
    Nov 2008
    Posts
    271

    Default

    Hi,
    I have not been using Windows for a long time, so this is a shot in the dark. Try and set again JAVA_HOME using the shortened path C:\Progra~1\Java\jdk1.6.0_27.
    Andrea Torre
    twitter: @andtorg

    join the community on ##pentaho - a freenode irc channel

  5. #5
    Join Date
    Dec 2009
    Posts
    609

    Default

    Hi again

    @Andrea: I doubt if "set JAVA_HOME=C:\Progra~1\Java\jdk1.6.0_27" will work...
    According to the output:

    D:\Office_YouView\Pentaho Installation\pdi-ee\data-integration>spoon.bat
    DEBUG: Using JAVA_HOME
    DEBUG: _PENTAHO_JAVA_HOME=C:\Program Files (x86)\Java\jdk1.6.0_27
    DEBUG: _PENTAHO_JAVA=C:\Program Files (x86)\Java\jdk1.6.0_27\bin\javaw
    DEBUG: PENTAHO_INSTALLED_LICENSE_PATH=

    The JRE should be found.

    So my question is: What happens? In spoon.bat, could you exchange "javaw" with "java" (erase the w) ?
    This should keep a console/commandline open in order to see more output/error messages.
    If you succeed in doing this, please come back with more error output for us to analyze

    Cheers,

    Tom

    P.S. I could think about:
    What would the PDI-EE do, if no licenses are found?
    This brings me to the question:
    Why do you install PDI-EE and not have Pentaho Support?
    I could imagine a problem with the spoon trying to look for licenses, not finding any and therefore just stopping again.
    Last edited by TomS; 08-11-2011 at 08:49 AM.

  6. #6
    Join Date
    Nov 2012
    Posts
    19

    Default

    Hi all,

    is there any solution to this problem? I encounter the same (or similar) problem with the PDI community edition: When i start Spoon.bat I get an error message telling me that javaw could not be found... any ideas?

    Thanks a lot!

    Cheers,

    Fabian

  7. #7

    Default

    Adding:

    set JAVA_HOME=C:\Program Files (x86)\Java\jre7

    or similar (depending on the path)

    prior to :

    set PENTAHO_JAVA=javaw

    solved it for me with the CE edition version 4.3.0

  8. #8
    Join Date
    Dec 2009
    Posts
    609

    Default

    To make it a bit more "general": you could also put your JAVA_HOME environment variable into your computer settings

  9. #9

    Thumbs up

    It's works on Windows 7 and PDI 4.40 CE:

    Replace set PENTAHO_JAVA=javaw by set PENTAHO_JAVA=C:\Program Files (x86)\Java\jre7\bin\javaw.exe

    :: **************************************************
    :: ** Kettle home **
    :: **************************************************


    if "%KETTLE_DIR%"=="" set KETTLE_DIR=%~dp0
    if %KETTLE_DIR:~-1%==\ set KETTLE_DIR=%KETTLE_DIR:~0,-1%


    cd %KETTLE_DIR%


    set PENTAHO_JAVA=C:\Program Files (x86)\Java\jre7\bin\javaw.exe
    set IS64BITJAVA=0


    call "%~dp0set-pentaho-env.bat"

  10. #10
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    TomS's solution is the correct one.

    Fixing it in any other way will actually force you to fix it over and over.
    **THIS IS A SIGNATURE - IT GETS POSTED ON (ALMOST) EVERY POST**
    I'm no expert.
    Take my comments at your own risk.

    PDI user since PDI 3.1
    PDI on Windows 7 & Linux

    Please keep in mind (and this may not apply to this thread):
    No forum member is going to do your work for you. We will help you sort out how to do a specific part of the work, as best we can, in the timelines that our work will allow us.
    Signature Updated: 2014-06-30

  11. #11
    Join Date
    Sep 2013
    Posts
    2

    Default

    pdi-ce-5.2.0.0-209 on Windows 7, jre 7 in C:\Program Files\Java\jre7

    Error text from the console:

    WARNING: Using java from path
    DEBUG: _PENTAHO_JAVA_HOME=
    DEBUG: _PENTAHO_JAVA=javaw.exe
    The system cannot find the path specified.
    The system cannot find the path specified.
    Having spent an embarrassing amount of time looking at this and the subsequent Fatal Error as the "Java Virtual Machine could not be created", this is what I found, for the benefit of other new users.

    spoon.bat uses set-pentaho-env.bat to find the location of java and create these variables accordingly:
    _PENTAHO_JAVA_HOME - C:\Program Files\Java\jre7
    _PENTAHO_JAVA - C:\Program Files\Java\jre7\bin\java.exe

    It looks for these system environment variables which should contain the path C:\Program Files\Java\jre7 to the java directory:
    PENTAHO_JAVA_HOME: manually created
    JAVA_HOME: expected if you have JDK installed
    JRE_HOME: expected if you have the JRE installed

    and puts the value it finds in _PENTAHO_JAVA_HOME.
    Having any of those three in the environment variables should work.

    WARNING: Using java from path
    I find misleading as this comes at the end of the search routine after it has checked all the locations in its list and still has not found java.


    DEBUG: _PENTAHO_JAVA_HOME=
    Manually putting _PENTAHO_JAVA_HOME in your environment variables will not work as set-pentaho-env.bat will SET it to whatever it decides or blank, which is what was happening in my installation initially. I mention this as I found elsewhere people mentioning to use _PENTAHO_JAVA_HOME as an environment variable.

    The subsequent line
    DEBUG: _PENTAHO_JAVA=javaw.exe
    is just a default setting in the batch file, it hasn't discovered it.

    Next
    The system cannot find the path specified.
    The system cannot find the path specified.
    are from trying to determine if its 64 or 32 bit and can’t find either as it is using nothing for a path to the exe.

    So just set one of the three variables as mentioned above and it should work.
    This page recommends setting PENTAHO_JAVA_HOME
    http://infocenter.pentaho.com/help48...e_windows.html

    BUT
    Without any variable set, despite the error messages Pentaho would start but I didn’t know if that meant it had magically found java anyway or it just did not need it to start.
    With a variable set, that cleared the spoon.bat error messages but then Pentaho would not start and I got “Java Virtual Machine could not be created” message which to cut an already long story short, was due to this parameter "-XX:MaxPermSize=256m” hard-coded in spoon.bat
    Code:
    if "%PENTAHO_DI_JAVA_OPTIONS%"=="" set PENTAHO_DI_JAVA_OPTIONS="-Xmx512m" "-XX:MaxPermSize=256m"
    If -XX:MaxPermSize was greater than 128m, it caused a fatal error.
    Setting it to -XX:MaxPermSize=128m or removing it completely allowed java to start.
    Last edited by torvista; 12-15-2014 at 04:30 PM.

  12. #12
    Join Date
    Jan 2015
    Posts
    1

    Default

    Any update on this issue. I'm puzzled why it doesn't work out the box? I've set my system variable as described but still get there error.
    C:\Users\xxx\Downloads\Pentaho\data-integration>spoon
    DEBUG: Using PENTAHO_JAVA_HOME
    DEBUG: _PENTAHO_JAVA_HOME=C:\Program Files (x86)\Java\jre7
    DEBUG: _PENTAHO_JAVA=C:\Program Files (x86)\Java\jre7\bin\javaw.exe


    C:\Users\xxx\Downloads\Pentaho\data-integration>start "Spoon" "C:\Program Fil
    es (x86)\Java\jre7\bin\javaw.exe" "-Xmx512m" "-XX:MaxPermSize=256m" "-Djava.lib
    rary.path=libswt\win32" "-DKETTLE_HOME=" "-DKETTLE_REPOSITORY=" "-DKETTLE_USER="
    "-DKETTLE_PASSWORD=" "-DKETTLE_PLUGIN_PACKAGES=" "-DKETTLE_LOG_SIZE_LIMIT=" "-D
    KETTLE_JNDI_ROOT=" -jar launcher\pentaho-application-launcher-5.2.0.0-209.jar -l
    ib ..\libswt\win32

  13. #13
    Join Date
    Jun 2015
    Posts
    6

    Default

    Quote Originally Posted by TomS View Post
    Hi,

    you downloaded the Enterprise-Edition? Can PDI not be started from within the Windows Start-Menu?
    Otherwise: Try setting your JAVA_HOME environment variable to the installation directory of your JRE:
    set JAVA_HOME=C:\Program Files (x86)\Java\jre6
    then rerun spoon.bat

    Cheers,

    Tom

    P.S. Another idea: Do not install in a directory-name which contains blanks
    Hello Tom,

    I have been doing R n D for the DEBUG issues from many days. Will appreciate if you could help me. Also As per your instruction this is what i did but still i don't see any luck of running spoon.sh but STILL THE DEBUG issue is not solved. PLEASE SUGGEST


    [pentaho@vertica-srv1 data-integration]$ vi spoon.sh


    BASEDIR="."
    cd "/home/pentaho/business_process/design-tools/data-integration"
    DIR=`pwd`
    cd -
    PENTAHO_JAVA_HOME=/usr/java/jdk1.7.0_79/jre/bin/javaws
    . "$DIR/set-pentaho-env.sh"

    setPentahoEnv

    # **************************************************
    # ** Platform specific libraries ... **
    # **************************************************

    LIBPATH="NONE"

    [pentaho@vertica-srv1 data-integration]$ ./set-pentaho-env.sh

    [pentaho@vertica-srv1 data-integration]$ ./spoon.sh

    /home/pentaho/business_process/design-tools/data-integration
    /home/pentaho/business_process/design-tools/data-integration
    DEBUG: Using PENTAHO_JAVA_HOME
    DEBUG: Found Pentaho License two folders up
    DEBUG: _PENTAHO_JAVA_HOME=/usr/java/jdk1.7.0_79/jre/bin/javaws
    DEBUG: _PENTAHO_JAVA=/usr/java/jdk1.7.0_79/jre/bin/javaws/bin/java
    DEBUG: PENTAHO_INSTALLED_LICENSE_PATH=/home/pentaho/business_process/design-tools/data-integration/../../.installedLicenses.xml
    ./spoon.sh: line 191: /usr/java/jdk1.7.0_79/jre/bin/javaws/bin/java: Not a directory
    [pentaho@vertica-srv1 data-integration]$ vi spoon.sh
    [pentaho@vertica-srv1 data-integration]$ ./set-pentaho-env.sh
    [pentaho@vertica-srv1 data-integration]$ ./spoon.sh
    /home/pentaho/business_process/design-tools/data-integration
    /home/pentaho/business_process/design-tools/data-integration
    DEBUG: Using PENTAHO_JAVA_HOME
    DEBUG: Found Pentaho License two folders up
    DEBUG: _PENTAHO_JAVA_HOME=/usr/java/jdk1.7.0_79/jre/bin/javaws
    DEBUG: _PENTAHO_JAVA=/usr/java/jdk1.7.0_79/jre/bin/javaws/bin/java
    DEBUG: PENTAHO_INSTALLED_LICENSE_PATH=/home/pentaho/business_process/design-tools/data-integration/../../.installedLicenses.xml
    ./spoon.sh: line 191: /usr/java/jdk1.7.0_79/jre/bin/javaws/bin/java: Not a directory
    [pentaho@vertica-srv1 data-integration]$



    [pentaho@vertica-srv1 bin]$ pwd
    /usr/java/jdk1.7.0_79/jre/bin
    [pentaho@vertica-srv1 bin]$ ls -al
    total 460
    drwxr-xr-x 2 root root 4096 Jun 22 20:10 .
    drwxr-xr-x 5 root root 4096 Jun 22 20:10 ..
    lrwxrwxrwx 1 root root 8 Jun 22 20:10 ControlPanel -> jcontrol
    -rwxr-xr-x 1 root root 7718 Apr 11 00:40 java
    -rwxr-xr-x 1 root root 19227 Apr 11 00:40 java_vm
    -rwxr-xr-x 1 root root 136828 Apr 11 00:40 javaws
    -rwxr-xr-x 1 root root 6391 Apr 11 00:35 jcontrol
    -rwxr-xr-x 1 root root 7925 Apr 11 00:40 keytool
    -rwxr-xr-x 1 root root 8117 Apr 11 00:40 orbd
    -rwxr-xr-x 1 root root 7957 Apr 11 00:40 pack200
    -rwxr-xr-x 1 root root 7981 Apr 11 00:40 policytool
    -rwxr-xr-x 1 root root 7925 Apr 11 00:40 rmid
    -rwxr-xr-x 1 root root 7933 Apr 11 00:40 rmiregistry
    -rwxr-xr-x 1 root root 7949 Apr 11 00:40 servertool
    -rwxr-xr-x 1 root root 8149 Apr 11 00:40 tnameserv
    -rwxr-xr-x 1 root root 219643 Apr 11 00:40 unpack200
    [pentaho@vertica-srv1 bin]$ pwd
    /usr/java/jdk1.7.0_79/jre/bin
    [pentaho@vertica-srv1 bin]$

    JUST INCASE IF YOU WANT TO SEE MORE JAVA OUTPUT INFORMATIONS THEN HERE IT IS :-

    [pentaho@vertica-srv1 jre]$ whereis java
    java: /usr/bin/java

    [pentaho@vertica-srv1 jre]$ which java
    /usr/bin/java

    [pentaho@vertica-srv1 jre]$ java -version
    java version "1.7.0_79"
    Java(TM) SE Runtime Environment (build 1.7.0_79-b15)
    Java HotSpot(TM) 64-Bit Server VM (build 24.79-b02, mixed mode)
    [pentaho@vertica-srv1 jre]$ javac -version
    javac 1.7.0_79

    [pentaho@vertica-srv1 jre]$ echo $JAVA_HOME
    /usr/java/jdk1.7.0_79

    [pentaho@vertica-srv1 jre]$ echo $PATH
    /usr/java/jdk1.8.0_45/bin:/usr/lib64/qt-3.3/bin:/usr/java/jdk1.8.0_45/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/java/jdk1.7.0_79/bin:/home/pentaho/bin:/usr/java/jdk1.7.0_79/bin

  14. #14
    Join Date
    Apr 2008
    Posts
    1,771

    Default

    Hi ujjwalrana,
    you have replied to an old post and it could be that in the meantime things have changed in the PDI world.
    Note that those instructions were referring to Windows, not Linux.

    Have you tried to follow instructions in the wiki pages?
    It looks like you have 2 different version of JAVA installed, 1.7 and 1.8 - surely that does not help.
    -- Mick --

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.