Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: Using PGP Encryption Step in PDI

  1. #1

    Default Using PGP Encryption Step in PDI

    I am running PDI on a Windows XP SP3 32-bit machine. I am currently trying to use the newer PGP encrypt/decrypt steps to encrypt a CSV file but I am running into some issues.

    As it states that it is required, I have installed GPG (in this case Gpg4Win). When I try to use the PGP encrypt step though I am getting an error when attempting to run the job (error attached as text file). I have a feeling that I am providing it with the wrong file for GPG, but I am not actually sure which file needs to be used. I currently have PDI using kleopatra.exe and have also tried gpg2.exe

    I guess my main question would be then, which file in the GPG directory am I actually supposed to be using in order for PDI to encrypt/decrypt my files?

    Thank you for the help in advance and let me know if you need anymore information.
    Attached Files Attached Files

  2. #2

    Default

    After doing a little testing, it seems like this only happens with jobs that I create in our Enterprise Repository.

    If I create the job in the repository and put anything in for the GPG location and try to run it, I get the above error. I subsequently can no longer open the job if I am to close it as I continue to get the above error. If I create the job and save it locally though, PDI actually tries to run the job and I get errors in the log. So I'm not really sure why it errors out in the repository but not locally.

  3. #3

    Default

    I've made very little progress, but I have made progress, lol.

    It appears that the only issue that I am now having is that I cannot find which application out of the GPG directory in Windows I need to be selecting as the GPG location in Pentaho. If anyone has used GPG4Win and knows this information, please let me know. Otherwise I am going to keep trying different things and will update if I can get it working.

    --10.4.11 Update

    Was able to figure out using GPG using the shell scripting steps in PDI. Will continue to go this route until I can figure out the PGP steps in PDI.
    Last edited by ccorliss; 10-04-2011 at 10:58 AM.

  4. #4

    Default

    I think this repository issue has been addressed in the latest stable release. I still haven't been able to get the step to work in Linux (seems like a quoting issue). Hopefully your problem is resolved.

  5. #5

    Default

    Quote Originally Posted by dbron0000 View Post
    I think this repository issue has been addressed in the latest stable release. I still haven't been able to get the step to work in Linux (seems like a quoting issue). Hopefully your problem is resolved.
    I'm actually having the same problem now. I'm able to get GPG4Win working without issue, the problem I am having now is that I cannot get it to work on our Linux PDI server.

    Any help would be greatly appreciated.

  6. #6

    Default

    Made a little bit of progress, I was pointing Pentaho at the wrong location.

    For anyone that needs it, the location I had to use is: /usr/bin/gpg

    I am now stuck with the following error though (key name replaced for confidentiality): Error running command: gpg: "x_x_x_PUBLIC_KEY": skipped: No public key

    I'll be opening up a support case on this as well, so I will provide details when finished.

  7. #7

    Default

    If anyone is following this thread I wanted to give a heads up that this does appear to be an application issue. I will update when I get another reply back from the support team with details.

  8. #8
    Join Date
    Jan 2013
    Posts
    108

    Default

    hi

    is there any updates/success? i do have the same question, it is not encrypting in my case also. i have to encrypt csv file, have pointed to gpg2.exe, gpg.exe, kleopatra.exe, also tried to point to my keys on gpg location field. it shows only success but doesn't give any result..

    thankful for any suggestions, newbie

  9. #9
    Join Date
    Mar 2015
    Posts
    7

    Default

    Has anyone been able to get to the bottom of this?

    I am on 5.2 Enterprise Edition and have the same issue. Where we can encrypt files while working locally but when running from the DI Repository then when running from the server we are getting "skipped: No public key".

    Nigel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.