Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Error while adding a new JDBC jar in Kettle

  1. #1
    Join Date
    Aug 2011
    Posts
    4

    Default Error while adding a new JDBC jar in Kettle

    Hi,

    Following is the option I tried to include the jar

    1.) Copied the jar file to java/jre/lib/ext
    2.) Copied the jar file to data-integration/libext/JDBC

    and then started the spool.bat. I gave the proper driver class in Kettle Transformation by chossing the Connection Type as Generic Database - Native JDBC


    When I run this transformation I get the following exception

    Exception while loading class
    com.metamatrix.jdbc.MMDriver


    Is there any other way to include a new jdbc jar and am I missing something here?

    Please help.

  2. #2
    Join Date
    Sep 2007
    Posts
    834

    Default

    data-integration/libext/JDBC is the proper folder.
    Does the driver work fine on other tools. i.e. squirrel?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.