Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Unable to Access Repository Security Tab

  1. #1

    Default Unable to Access Repository Security Tab

    I am having a weird issue that no one (including Pentaho Support) has been able to figure out, so I wanted to present it to the community to see if there were any suggestions, or possibly other people having the issue.

    Issue:

    I am an administrator (full access to everything) in all 3 Enterprise Repositories that we currently have setup, each repository is on a separate sever. I am able to explore the repository without issue and when exploring, I am able to access all tabs with the exception of the Security tab. When I attempt to access the security tab, I am receiving the attached error. Unfortunately, Spoon will not allow me to copy the error, so I had to take a screen shot.

    We have another administrator who is able to access the security tab in the repository explorer on all three repositories without issue.

    I have tried using several different user accounts and I get the same result, so it doesn't appear to be an account issue (just for good measure, we have deleted all the accounts I have tried and created new ones).

    If anyone has any suggestions, please let me know.
    Attached Images Attached Images  

  2. #2

    Default

    Forgot that I did type out the error. Since I did type it out, there is a possibility that there are typos.

    Unable to initialize Security tab: org.pentaho.di.core.exception.kettleException:
    Unable to get users
    at org.pentaho.commons.launcher.Launcher.main (Launcher.java:134)
    at java.lang.reflect.Method.invoke (null:-1)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke (null:-1)
    at sun.reflect.NativeMethodAccessorImpl.invoke (null:-1)
    at sun.reflect.NativeMethodAccessorImpl.invoke0 (null:-2)
    at org.pentaho.di.ui.spoon.Spoon.main (Spoon.java:553)
    at org.pentaho.di.ui.spoon.Spoon.start (Spoon.java:6938)
    at org.pentaho.di.ui.spoon.Spoon.readAndDispatch (Spoon.java:1169)
    at org.eclipse.swt.widgets.Display.readAndDispatch (null:-1)
    at org.eclipse.swt.widgets.Display.runAsyncMessages (null:-1)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages (null:-1)
    at org.eclipse.swt.widgets.RunnableLock.run (null:-1)
    at org.pentaho.di.ui.spoon.Spoon$21$1.run (Spoon.java:3488)
    at org.pentaho.di.ui.repository.repositoryexplorer.RepositoryExplorer.show (RepositoryExplorer.java:127)
    at org.pentaho.ui.xul.swt.tags.SwtDialog.show (SwtDialog.java:304)
    at org.pentaho.ui.xul.swt.tags.SwtDialog.show (SwtDialog.java:378)
    at org.eclipse.jface.window.Window.open (Window.java:796)
    at org.eclipse.jface.window.Window.runEventLoop (Window.java:820)
    at org.eclipse.swt.widgets.Display.readAndDispatch (null:-1)
    at org.eclipse.swt.widgets.Display.runDeferredEvent (null:-1)
    at org.eclipse.swt.widgets.Widget.sendEvent (null:-1)
    at org.eclipse.swt.widgets.EventTable.sendEvent (null:-1)
    at org.eclipse.swt.custom.CTabFolder$1.handleEvent (null:-1)
    at org.eclipse.swt.custom.CTabFolder.onMouse (null:-1)
    at org.eclipse.swt.custom.CTabFolder.ssetSelection (null:-1)
    at org.eclipse.swt.widgets.Widget.notifyListeners (null:-1)
    at org.eclispe.swt.widgets.Widget.sendEvent (null:-1)
    at org.eclipse.swt.widgets.Widget.sendEvent (null:-1)
    at org.eclipse.swt.widgets.Widget.sendEvent (null:-1)
    at org.eclipse.swt.widgets.EventTable.sendEvent (null:-1)
    at org.eclipse.swt.widgets.TypedListener.handleEvent (null:-1)
    at org.pentaho.ui.xul.swt.tags.SwtTabbox$1.widgetSelected (SwtTabbox.java:78)
    at org.pentaho.ui.xul.swt.tags.SwtTabbox.access$200 (SwtTabbox.java:123)
    at org.pentaho.ui.xul.impl.AbstractXulComponent.invoke (AbstractXulComponent.java:123)
    at org.pentaho.ui.xul.impl.AbstractXulCompnent.invoke (AbstractXulComponent.java:139)
    at org.pentaho.ui.xul.impl.AbstractXulDomContainer.invoke (AbstractXulDomContainer.java:329)
    at java.lang.reflect.method.invoke (null:-1)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke (null:-1)
    at sun.reflect.NativeMethodAccessorImpl.invoke (null:-1)
    at sun.reflect.NativeMethodAccessorImpl.invoke0 (null:-2)
    at org.pentaho.di.ui.repository.repositoryexplorer.controllers.SecurityController.tabClicked (SecurityController.java:372)
    at org.pentaho.di.ui.repository.repositoryexplorer.controllers.LazilyInitalizedController.lazyInit (LazyilyInitializedController.java:28)
    at org.pentaho.di.ui.repository.pur.repositoryexplorer.controller.EESecurityController.doLazyInit (SourceFile:167)
    at org.pentaho.di.ui.repository.repositoryexplorer.controllers.SecurityController.doLazyInit (SecurityController.java:100)
    at org.pentaho.di.ui.repsotiroy.pur.repositoryexplorer.controller.EESecurityController.createModel (SourceFile:195)
    at org.pentaho.di.ui.repository.repositoryexplorer.controllers.SecurityAController.createModel (SecurityController.java:144)
    at org.pentaho.di.ui.respository.pur.repositoryexplorer.abs.controller.AbsController.createSecurity (sourceFile:133)
    at org.pentaho.di.ui.repository.pur.repositoryexplorer.abs.model.UIAbsSecurity <init> (SourceFile:19)
    at org.pentaho.di.ui.respository.pur.repositoryexplorer.model.UIEESecurity <init> (SourceFile:42)
    at org.pentaho.di.ui.repository.respositoryexplorer.model.UISecurity <init> (UISecurity.java:42)
    at org.pentaho.di.repository.pur.c.getUsers (SourceFile:131)
    at org.pentaho.di.repository.pur.b.getUsers (SourceFile:178)
    at org.pentaho.di.repository.pur.d.a (SourceFile:36)

  3. #3
    Join Date
    Feb 2011
    Posts
    4

    Default Use JRE6

    I also had this problem while running Java JRE 1.7... It works fine now after I uninstalled JRE 1.7 and installed JRE 1.6

  4. #4

    Default

    Thank you Eric.

    If anyone in the future has this issue, I can confirm that it was something in JRE 7 that was causing the problem. I uninstalled 7 and set 6 back up and I am no longer having any issues.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.