Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Scheduled Kettle job not running...

  1. #1
    Join Date
    Sep 2011

    Question Scheduled Kettle job not running...


    I have some Kettle jobs that I have been running by hand using Kitchen.
    Now I want to run them scheduled daily from within BI server (biserver-ce-3.8.0-stable)

    I created an xaction using Design Studio/Eclipse to set the main job and setting the logging files. It is file-based, no repository yet.

    I added an entry in the Scheduler using PAC that calls this xaction.

    When I run the schedule-item nothing seems to happen. It finishes almost instantly while the job should take a couple of hours.

    Any I idea what could be the problem? What log files can I check to see what's going on (none seem te be touched when I run the schedule-item).


  2. #2



    did you try to start your xaction via PUC instead of the scheduler ?
    PUC will display some error messages when the xaction fails.
    xaction errors should normally be logged into catalina.out
    Within the xaction you can adjust the logging level, try DEBUG here.


  3. #3
    Join Date
    Sep 2011


    Cheers! I hadn't thought of this...

    However, I get this error, it just says: cannot execute this activity. I'm going to do some more digging to find out why not...

    The Pentaho BI Platform reported an error while running an action sequence

    Possible Causes:RuntimeContext.ERROR_0017 - Activiteit kon niet worden uitgevoerd
    Action Sequence:RunFamedDWH.xaction
    Execution Stack:EXECUTING ACTION: Pentaho Data Integration Job dwh_alleElementen.kjb (KettleComponent)
    Loop Index (1-based):0
    Error Time:dinsdag 27 september 2011 9:59:01 uur CEST
    Error Type:ActionExecutionException
    Session ID:joe
    Instance Id:8fb7407f-e8de-11e0-a4fc-97030a141eef
    Action Class:KettleComponent
    Action Description:Pentaho Data Integration Job dwh_alleElementen.kjb

    Stack Trace:org.pentaho.platform.api.engine.ActionExecutionException: RuntimeContext.ERROR_0017 - Activiteit kon niet worden uitgevoerd at at


    rg.apache.coyote.http11.Http11AprProcessor.process( at org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process( at$ at

    Server Version: Pentaho Platform Engine Core 3.8.0-stable.45256

  4. #4



    how I love this ERROR_0017 :-) ... could you post the xaction file ?


  5. #5
    Join Date
    Sep 2011


    As you may see, the current joblocation is on a network drive (O:\...) but I also tried putting a jobfile in the root (C:\) and tried both forward and backwardslashes ni the path, as well as trying a different job alltogether.
    Attached Files Attached Files

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.