Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Issue - 'No log table has been defined for the transformation'

  1. #1
    Join Date
    Aug 2011

    Default Issue - 'No log table has been defined for the transformation'


    I have a new job (kjb) and I am calling a transformation that I have in many other jobs but when I try to run this new job I am getting :-

    ERROR 17-10 16:17:38,655 - Transformation - org.pentaho.di.core.exception.KettleTransException:
    There was an error calculating the change data capture date range, it probably involved log table .
    No log table has been defined for the transformation.

    Thing is, that I am not using CDC, I am just trying to initialize some environment variables.

    As I say the same transformation is running OK in other jobs.

    I have done a search and it seemed to be and issue with Postgre but I am using mysql with PDI 4.1.0. If I use a 'set variables' component to set the environment variables - the job runs fine.

    I have tried to create a totally new job but still get same issue.

    Is it something to do with the log tables we use on mysql - should I do a table repair?

    And ideas would be helpful.


  2. #2
    Join Date
    Dec 2014


    I could resolve this by re-setting various log tables [remove and then add] entries from Logging tab [Step, Logging Channel]!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.