Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Can't establish PDI database connection to LucidDB.

  1. #1

    Default Can't establish PDI database connection to LucidDB.

    PDI version: 4.2
    LucidDB version: 0.9.3 64-bit
    Platform: Windows 7

    After installing LucidDB, starting the server, and establishing a connection to it using Squirrel, I created a new schema called TESTDW and added two tables to it: DIM_DATE and DIM_TIME. This schema was automatically placed under LOCALDB. Please see screenshot 001.jpg.

    I then wanted to view these tables in PDI. I created a new database connection and entered the information as follows:

    Connection Name: testdw_lucid
    Host Name: localhost
    Database Name: LocalDB
    Port Number: 8034
    User Name: sa

    When I clicked 'Test', it showed the connection was successful. Please see screenshot 002.jpg. The JDBC driver is in the libext folder and is the same one I use for Squirrel.

    After creating the connection, I dragged a Table Input widget onto the canvas, chose the right connection, and clicked 'Get SQL select statement...' to check if I could access the tables. What I get was a messagebox with the following error message:

    Unable to retrieve database information because of an error
    at org.eclipse.jface.operation.ModalContext$ (
    at org.pentaho.di.ui.core.database.dialog.GetDatabaseInfoProgressDialog$ (
    at org.pentaho.di.core.database.DatabaseMetaInformation.getData (
    at de.simplicit.vjdbc.VirtualDatabaseMetaData.getCatalogs (
    at de.simplicit.vjdbc.VirtualDatabaseMetaData.queryResultSet (
    at de.simplicit.vjdbc.util.SQLExceptionHelper.wrap (

    I clicked on 'Details', and received further information. Please see Screenshot003.jpg.

    I then clicked Close on the details window, and OK on the initial error messagebox, and was taken to a Database Explorer window with no tables. Please see Screenshot004.jpg.

    I tried variations on this process such as:
    a) Renaming the database name to LOCALDB.TESTDW in database connections.
    b) Manually typing a select statement (SELECT * FROM TESTDW.DIM_DATE)

    Each time, I get the same result.

    Could you please tell me what I'm doing wrong? Thank you for reading.
    Attached Images Attached Images     

  2. #2
    Join Date
    Sep 2009


    Hi there,

    not sure about the specific causes here, but for LucidDB it used to be beneficial to have users and their schemas tied together. I.e. create a schema, make it the default for a LucidDB user and create a connection with that user. It should put you into the user's schema by default, thus allowing you to see his tables.

    PS: it's worth posting this in too


  3. #3


    Update: I never did solve this problem.

    But switching to LucidDb 0.9.4 on Linux helped me avoid the issue altogether. Everything worked fine after that.

  4. #4


    I am experimenting the same issue how can I create a user and a schema , plz help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.