Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Database Connection error

  1. #1

    Unhappy Database Connection error

    Hi!
    Currently using PDI4.1.4

    We have created a new mySQL database host. It does connect with MySQL Workbench, but with the same credentials it does not seem to establish the connection within PDI. Does anyone know or is familiar with the error output below?

    Error connecting to database [mysql_test] : org.pentaho.di.core.exception.KettleDatabaseException:
    Error occured while trying to connect to the database.

    Error connecting to database: jdbc:mysql://50.5.55.55:3306/tpe_ept?defaultFetchSize=500&useCursorFetch=true (using class org.gjt.mm.mysql.Driver)
    Unknown initial character set index '192' received from server. Initial client character set can be forced via the 'characterEncoding' property.
    How does one re-/configure this for it to work?

  2. #2
    Join Date
    Mar 2008
    Posts
    140

    Default

    This MySQL bug looks related: http://bugs.mysql.com/bug.php?id=22456

    Try adding 'useUnicode=true&characterEncoding=UTF8' to your JDBC url as does the following statement.

    jdbc:mysql://10.10.4.110:3306/wops_album?useUnicode=true&characterEncoding=UTF8


    In PDI you should be able to accomplish this by adding parameters to the "Options" section of your database configuration.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.