Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: LucidDB Streaming Loader won't open port 9034.

  1. #1

    Default LucidDB Streaming Loader won't open port 9034.

    PDI: v4.1.3
    LucidDB: 0.9.3 (With the Remote Rows patch)
    Platform: Windows 7

    I'm using 0.9.3 because 0.9.4 isn't available for windows yet.

    I managed to establish a connection to this local LucidDB installation in PDI (I can explore the schemas and tables). To test the streaming loader, I have a table input feeding rows from a local MySql database. I set the target schema, target table, host (localhost), and port (9034).

    When I run the transformation, I get the message: Local socket connection is not ready, so try again in 5 seconds. I receive this message five times, and then the transformation quits with errors messages. I also checked netstat when the transformation was running, and saw that 9034 never opened (8034 was there). This is the error message:

    2011/11/04 19:32:48 - LucidDB Streaming Loader.0 - ERROR (version 4.1.3, build 15232 from 2011-05-27 00.00.18 by root) : Error in step, asking everyone to stop because of:
    2011/11/04 19:32:48 - LucidDB Streaming Loader.0 - ERROR (version 4.1.3, build 15232 from 2011-05-27 00.00.18 by root) : org.pentaho.di.core.exception.KettleException:
    2011/11/04 19:32:48 - LucidDB Streaming Loader.0 - ERROR (version 4.1.3, build 15232 from 2011-05-27 00.00.18 by root) : Fatal Error: Remote_rows UDX can't be connected! Please check...
    2011/11/04 19:32:48 - LucidDB Streaming Loader.0 - ERROR (version 4.1.3, build 15232 from 2011-05-27 00.00.18 by root) :
    2011/11/04 19:32:48 - LucidDB Streaming Loader.0 - ERROR (version 4.1.3, build 15232 from 2011-05-27 00.00.18 by root) : at org.pentaho.di.trans.steps.luciddbstreamingloader.LucidDBStreamingLoader.processRow(LucidDBStreamingLoader.java:203)
    2011/11/04 19:32:48 - LucidDB Streaming Loader.0 - ERROR (version 4.1.3, build 15232 from 2011-05-27 00.00.18 by root) : at org.pentaho.di.trans.step.RunThread.run(RunThread.java:40)
    2011/11/04 19:32:48 - LucidDB Streaming Loader.0 - ERROR (version 4.1.3, build 15232 from 2011-05-27 00.00.18 by root) : at java.lang.Thread.run(Unknown Source)

    Any idea on what I may be doing wrong? Thank you.

  2. #2

    Default

    Update: I never solved this problem.

    Switching to LucidDb 0.9.4 on Linux and running it on a dedicated server (as opposed to Virtualbox) helped me avoid the issue. Everything worked fine after that.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.