Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: [HELP] can not retrieve database information

  1. #1
    Join Date
    Nov 2011
    Posts
    1

    Unhappy [HELP] can not retrieve database information

    hello PDI experts
    i am new with PDI
    i'm using PDI 4.2 stable

    my source data is from mysql, connected well

    and my destination is to sybase iq 15
    when i try to explore the database information when i make a connection
    i got error like this :
    Code:
    Unable to retrieve database information because of an error
    
    Unable to get list of procedures from database meta-data: 
    
    Unable to get list of rows from ResultSet : 
    
    Couldn't get row from result set
    
    Unable to get value 'String(254)' from database resultset, index 6
    [Microsoft][ODBC Driver Manager] Invalid string or buffer length
    i have tried increase Buffer Size in ODBC, but nothing change in PDI when i try to explore database information
    same error occure

    and i have tried send data to Microsoft Excel Output, and it works well
    but not with Table Output

    is there any clue?

    many thanks before...

  2. #2
    Join Date
    Dec 2005
    Posts
    2

    Default

    Hello,

    Not sure if you have resolved this error, I had a similar problem when moving data from Sybase IQ to MySQL. I solved the issue by casting the field giving the error.

    Original SQL
    Code:
    SELECT fieldname FROM tablename
    Modified SQL
    Code:
    SELECT convert(VARCHAR(400), fieldname) FROM tablename

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.