Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: JPivot gives Resultset Overflow Occured

  1. #1
    Join Date
    Apr 2011
    Posts
    4

    Post JPivot gives Resultset Overflow Occured

    I am using JPivot that ships with Pentaho 3.8.0.stable.45256. Whenever I try to drill down in a JPivot report it gives me Resultset Overflow Occurred. When I second time click on the + sign and drill down it works. I googled for this and found that it comes because of the settings in mondrian.properties. Following are the settings that I did as per instructions in one of the Pentaho forum:


    mondrian.result.limit=0
    mondrian.olap.case.sensitive=false
    mondrian.native.crossjoin.enable=false
    mondrian.native.ExpandNonNative=false

    All of the above setting are placed in pentaho-solutions/system/mondrian/mondrian.properties. And did restarted the Pentaho. But the error still persist. It looks like either these chages are not taking effect or there is some issue with the Query that is generated by JPivot.

    I enabled the log4j to verify the query and looked into the logs when error occurred. There is no error logged in the log file nor even the query generated when I drill down. It only shows the MDX query. Other reports that are running good, I see SQL queries logged for them. If this error is due to the sql query then it should not even run second time. But it does.

    There is no issue with the custom schema that created for my purpose as it works in Mondrian and does not give me any kind of Resultset overflow Error.

    What could be the issue? can it be because of Java heap Memory getting Overflowed? Is this some bug in the jpivot that I am using?
    1. JPivot settings somewhere that I am missing?
    2. MySQL query not getting generated correctly? If yes then how do I find the query, as it is not in logs.
    3. Java Heap Memory?
    FYI:
    1. RAM: 16GB
    2. There are more than 45 million records in the table which are aggregated.
    3. The CATALINA_OPTs settings are:
    -d64 -server -Xms2048m -Xmx6144m -XX:PermSize=256m -XX:MaxPermSize=1024m -XX:+UseLargePages -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Dlog4j.configuration=file:log4j.properties
    Last edited by srahul07; 11-18-2011 at 03:16 AM. Reason: correcting the mondrian properties file name

  2. #2
    Join Date
    Apr 2011
    Posts
    4

    Default

    Got the solution to my problem.

    I have increased the session and query time out in Pentaho as well as increased the timeout of my tomcat and Apache (Serve as a proxy server) and that helped. It is working now and I have also made one of the above parameter to true as shown here:

    mondrian.native.crossjoin.enable=true

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.